summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDct Mei2019-06-19 16:07:35 +0900
committerDct Mei2019-06-19 16:07:35 +0900
commit1ea769e48ed4fd00425385cf74b824bb58744c02 (patch)
tree9002b5a9fe023acba1b3aeb376716ade21d9b5fc
parent1a60d76215a1c96d76beda7f0d86f2cf85e4ae2e (diff)
downloadaur-1ea769e48ed4fd00425385cf74b824bb58744c02.tar.gz
fix
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD49
-rwxr-xr-xgit.sh9
-rw-r--r--grub-theme-slaze-git.install16
4 files changed, 33 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed13e36d76fa..9884bd78df70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Tue Feb 12 05:53:20 UTC 2019
pkgbase = grub-theme-slaze-git
- pkgdesc = slaze grub2 theme
- pkgver = 1.1
+ pkgdesc = Slaze grub theme
+ pkgver = 1.0
pkgrel = 1
url = https://github.com/vinceliuice/grub2-themes
- install = grub-theme-slaze-git.install
arch = any
- license = GPL
+ license = GPL3
makedepends = git
depends = grub
- optdepends = grub-customizer
- source = git://github.com/vinceliuice/grub2-themes
+ provides = grub-theme-slaze
+ conflicts = grub-theme-slaze
+ source = grub-theme-slaze::git+https://github.com/vinceliuice/grub2-themes.git
md5sums = SKIP
pkgname = grub-theme-slaze-git
diff --git a/PKGBUILD b/PKGBUILD
index 80c5beed6cf2..222cb8f96b0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
-# Maintainer: erik dubois <erik.dubois@gmail.com>
+# Maintainer: Dct Mei <dctxmei@gmail.com>
pkgname=grub-theme-slaze-git
-pkgver=1.1
+_pkgname="${pkgname%-*}"
+pkgver=1.0
pkgrel=1
-pkgdesc='slaze grub2 theme'
+pkgdesc="Slaze grub theme"
arch=(any)
-url='https://github.com/vinceliuice/grub2-themes'
-license=('GPL')
-depends=('grub')
-optdepends=('grub-customizer')
-makedepends=('git')
-conflicts=()
-install=${pkgname}.install
-source=('git://github.com/vinceliuice/grub2-themes')
-md5sums=('SKIP')
+url="https://github.com/vinceliuice/grub2-themes"
+license=('GPL3')
+depends=(grub)
+makedepends=(git)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://github.com/vinceliuice/grub2-themes.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
package() {
- install -dm755 $pkgdir/boot/grub/themes/
- cd grub2-themes/grub-theme-slaze
- cp -r Slaze $pkgdir/boot/grub/themes/
-
- echo '======='
- echo -e 'You should:\n1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/StylishDark/theme.txt"\e[0m'
- echo -e '\e[0m \n2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m'
- echo '----------'
- echo -e 'also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub'
- echo '======='
+ name="${pkgdesc%% *}"
+ cd "$srcdir/$_pkgname"
+ install -d "$pkgdir/boot/grub/themes/$name"
+ install -d "$pkgdir/boot/grub/themes/$name/icons"
+ install -Dm 755 common/* "$pkgdir/boot/grub/themes/$name"
+ install -Dm 755 "backgrounds/background-${_pkgname##*-}.jpg" "$pkgdir/boot/grub/themes/$name/background.jpg"
+ install -Dm 755 assets/assets-white/icons/* "$pkgdir/boot/grub/themes/$name/icons"
+ install -Dm 755 assets/assets-white/select/*.png "$pkgdir/boot/grub/themes/$name"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}
diff --git a/git.sh b/git.sh
deleted file mode 100755
index de402d198f40..000000000000
--- a/git.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/bash
-mksrcinfo
-git add --all .
-echo "####################################"
-echo "Write your commit comment!"
-echo "####################################"
-read input
-git commit -m "$input"
-git push -u origin master
diff --git a/grub-theme-slaze-git.install b/grub-theme-slaze-git.install
deleted file mode 100644
index 5f6a0abdb253..000000000000
--- a/grub-theme-slaze-git.install
+++ /dev/null
@@ -1,16 +0,0 @@
-read -r -d '' msg << TIPS
-====================================\n
-You should:\n
-1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/StylishDark/theme.txt"\e[0m\e[0m \n
-2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m
-\n------------------------------------\n
-also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub\n
-====================================
-TIPS
-post_install(){
- echo -e $msg
-}
-
-post_upgrade(){
- echo -e $msg
-}