summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlevinit2018-01-06 15:37:51 +0800
committerlevinit2018-01-06 15:37:51 +0800
commitb4fd1bba55e95ffc6838b8c5b4005a942e190cc4 (patch)
treecdc7b9350d61c529e1f4d683a76870a0092ec81b
downloadaur-b4fd1bba55e95ffc6838b8c5b4005a942e190cc4.tar.gz
1st commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--grub-themes-vimix.install16
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f28ec614b2e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = grub-themes-vimix
+ pkgdesc = vimix grub2 theme
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/vinceliuice/grub2-themes
+ install = grub-themes-vimix.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = grub
+ optdepends = grub-customizer
+ source = git://github.com/vinceliuice/grub2-themes
+ md5sums = SKIP
+
+pkgname = grub-themes-vimix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52561f20a4d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: levinit <levinit@outlook.com>
+
+pkgname=grub-themes-vimix
+pkgver=1.0
+pkgrel=1
+pkgdesc='vimix grub2 theme'
+arch=(any)
+url='https://github.com/vinceliuice/grub2-themes'
+license=('GPL')
+depends=('grub')
+optdepends=('grub-customizer')
+makedepends=('git')
+install=${pkgname}.install
+
+source=('git://github.com/vinceliuice/grub2-themes')
+
+md5sums=('SKIP')
+
+package() {
+ install -dm755 $pkgdir/boot/grub/themes/
+ cd grub2-themes/grub-themes-vimix
+ cp Vimix $pkgdir/boot/grub/themes/ -r
+
+ echo '======='
+ echo -e 'You should:\n1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/StylishDark/theme.txt"\e[0m'
+ echo -e '\e[0m \n2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m'
+ echo '----------'
+ echo -e 'also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub'
+ echo '======='
+}
+
diff --git a/grub-themes-vimix.install b/grub-themes-vimix.install
new file mode 100644
index 000000000000..5f6a0abdb253
--- /dev/null
+++ b/grub-themes-vimix.install
@@ -0,0 +1,16 @@
+read -r -d '' msg << TIPS
+====================================\n
+You should:\n
+1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/StylishDark/theme.txt"\e[0m\e[0m \n
+2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m
+\n------------------------------------\n
+also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub\n
+====================================
+TIPS
+post_install(){
+ echo -e $msg
+}
+
+post_upgrade(){
+ echo -e $msg
+}