summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-11-28 14:41:01 +0800
committermaz-12015-11-28 14:41:01 +0800
commit2713f8cb6d6ca6db602726e102b8eea2675f92c5 (patch)
tree30139b342793e7b7576c9802f5b23872bc2d61b1
parent1f8f3e82e7e965c4ac8e62959991771893db3ef4 (diff)
downloadaur-2713f8cb6d6ca6db602726e102b8eea2675f92c5.tar.gz
fix
-rw-r--r--PKGBUILD1
-rw-r--r--port_to_kf5.patch15
2 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 598e520674f0..4b043284b344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,7 @@ md5sums=('b3ff8fb938be8112dcc6e42b3e56efc6'
prepare() {
+ rm -rf build
mkdir -p build
cd kcm-grub2-$pkgver
patch -p1 -i "$srcdir/port_to_kf5.patch"
diff --git a/port_to_kf5.patch b/port_to_kf5.patch
index 52fab59d04b1..e9a23266ec91 100644
--- a/port_to_kf5.patch
+++ b/port_to_kf5.patch
@@ -448,15 +448,13 @@ diff -Naur a/src/installDlg.cpp b/src/installDlg.cpp
for (int i = 0; i < ui->treeWidget_recover->topLevelItemCount(); i++) {
QRadioButton *radio = qobject_cast<QRadioButton *>(ui->treeWidget_recover->itemWidget(ui->treeWidget_recover->topLevelItem(i), 0));
if (radio && radio->isChecked()) {
-@@ -102,7 +108,8 @@
+@@ -102,7 +108,4 @@
installAction.setParentWidget(this);
#endif
- if (installAction.authorize() != Action::Authorized) {
-+ //if (installAction.authorize() != Action::Authorized) {
-+ if (installAction.status() != Action::AuthorizedStatus) {
- return;
- }
+- return;
+- }
@@ -112,19 +119,21 @@
progressDlg.progressBar()->setMinimum(0);
@@ -468,10 +466,11 @@ diff -Naur a/src/installDlg.cpp b/src/installDlg.cpp
- if (reply.succeeded()) {
+ ExecuteJob* reply = installAction.execute();
+ connect(reply, SIGNAL(actionPerformed(ActionReply)), &progressDlg, SLOT(hide()));
-+ if (reply == 0) {
++ if (reply->exec()) {
KDialog *dialog = new KDialog(this, Qt::Dialog);
dialog->setCaption(i18nc("@title:window", "Information"));
- dialog->setButtons(KDialog::Ok | KDialog::Details);
+- dialog->setButtons(KDialog::Ok | KDialog::Details);
++ dialog->setButtons(KDialog::None);
dialog->setModal(true);
dialog->setDefaultButton(KDialog::Ok);
dialog->setEscapeButton(KDialog::Ok);
@@ -598,7 +597,7 @@ diff -Naur a/src/kcm_grub2.cpp b/src/kcm_grub2.cpp
- KMessageBox::createKMessageBox(dialog, QMessageBox::Information, i18nc("@info", "Successfully saved GRUB settings."), QStringList(), QString(), 0, KMessageBox::Notify, reply.data().value("output").toString()); // krazy:exclude=qclasses
+ //dialog->setDefaultButton(KDialog::Ok);
+ //dialog->setEscapeButton(KDialog::Ok);
-+ QDialogButtonBox *btnbox = new QDialogButtonBox(QDialogButtonBox::Ok);
++ QDialogButtonBox *btnbox = new QDialogButtonBox(QDialogButtonBox::NoButton);
+ KMessageBox::createKMessageBox(dialog, btnbox, QMessageBox::Information, i18nc("@info", "Successfully saved GRUB settings."), QStringList(), QString(), 0, KMessageBox::Notify, reply->data().value("output").toString()); // krazy:exclude=qclasses
load();
} else {