summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-11-27 15:12:34 +0800
committermaz-12015-11-27 15:12:34 +0800
commitea3c748a18419597ede3fa8f01486a56cf3b9e26 (patch)
tree4d470b09bd8431285470dd3d15267ced43627b56
parent8367bfec2aaa8bcba104eb4c26d791f4fd2531b7 (diff)
downloadaur-ea3c748a18419597ede3fa8f01486a56cf3b9e26.tar.gz
fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--port_to_kf5.patch4
3 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0523fa046a21..0c0841ea3c0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,6 +14,8 @@ pkgbase = grub2-editor-frameworks
depends = grub
depends = kcmutils
depends = kauth
+ depends = hwinfo
+ depends = imagemagick
provides = grub2-editor
conflicts = grub2-editor
source = http://sourceforge.net/projects/kcm-grub2/files/kcm-grub2-0.6.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 00f58e7e973b..598e520674f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url='https://ksmanis.wordpress.com/projects/grub2-editor/'
license=('GPL')
provides=grub2-editor
conflicts=grub2-editor
-depends=('kdelibs4support' 'grub' 'kcmutils' 'kauth')
+depends=('kdelibs4support' 'grub' 'kcmutils' 'kauth' 'hwinfo' 'imagemagick')
makedepends=('extra-cmake-modules' 'git' 'kdoctools')
source=("http://sourceforge.net/projects/kcm-grub2/files/kcm-grub2-$pkgver.tar.gz"
"port_to_kf5.patch"
diff --git a/port_to_kf5.patch b/port_to_kf5.patch
index 86e2b3988725..8a50de709ab4 100644
--- a/port_to_kf5.patch
+++ b/port_to_kf5.patch
@@ -19,7 +19,7 @@ diff -Naur kcm-grub2-0.6.4/CMakeLists.txt kcm-grub2-0.6.4-new2/CMakeLists.txt
+include(FeatureSummary)
+
+find_package(Qt5 REQUIRED COMPONENTS Widgets)
-+find_package(KF5 REQUIRED COMPONENTS KDELibs4Support Solid) #CoreAddons
++find_package(KF5 REQUIRED COMPONENTS KDELibs4Support Solid I18n) #CoreAddons
+
+
include(GRUBPaths)
@@ -275,7 +275,7 @@ diff -Naur kcm-grub2-0.6.4/src/CMakeLists.txt kcm-grub2-0.6.4-new2/src/CMakeList
# Set Link Libraries
-set(kcm_grub2_LINK_LIBS ${KDE4_KDEUI_LIBS} ${KDE4_KIO_LIBS} ${KDE4_SOLID_LIBS})
-+set(kcm_grub2_LINK_LIBS KF5::KDELibs4Support KF5::KIOCore KF5::Solid)
++set(kcm_grub2_LINK_LIBS KF5::KDELibs4Support KF5::KIOCore KF5::Solid KF5::I18n)
if(HAVE_IMAGEMAGICK)
set(kcm_grub2_LINK_LIBS ${kcm_grub2_LINK_LIBS} ${ImageMagick_LIBRARIES})
endif(HAVE_IMAGEMAGICK)