summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Lourenço2020-06-29 09:11:25 +0100
committerRodrigo Lourenço2020-06-29 09:11:25 +0100
commit004a65f664350a5824e87a91b8cf51735d5458d1 (patch)
tree545933bab594b483dbfcba14d538479c38737234
downloadaur-004a65f664350a5824e87a91b8cf51735d5458d1.tar.gz
Initial packaging
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38466751e374
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = grub2-theme-fallout-git
+ pkgdesc = Fallout GRUB theme
+ pkgver = 0+41.gcd6cf16
+ pkgrel = 1
+ url = https://github.com/shvchk/fallout-grub-theme
+ arch = any
+ license = MIT
+ makedepends = git
+ source = git+https://github.com/shvchk/fallout-grub-theme
+ md5sums = SKIP
+
+pkgname = grub2-theme-fallout-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46da321966ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Rodrigo Lourenço <rzl@rzl.ooo>
+
+pkgname=grub2-theme-fallout-git
+pkgver=0+41.gcd6cf16
+pkgrel=1
+pkgdesc="Fallout GRUB theme"
+url=https://github.com/shvchk/fallout-grub-theme
+arch=('any')
+license=('MIT')
+depends=()
+makedepends=('git')
+source=('git+https://github.com/shvchk/fallout-grub-theme')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fallout-grub-theme
+ echo "0+$(git rev-list --all | wc -l).g$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd fallout-grub-theme
+ install -v -Dm644 -t "$pkgdir/usr/share/grub/themes/fallout-grub-theme" \
+ background.png \
+ fixedsys-regular-32.pf2 \
+ item_c.png \
+ selected_item_c.png \
+ terminal_box_c.png \
+ theme.txt
+ install -v -Dm644 -t "$pkgdir/usr/share/grub/themes/fallout-grub-theme/icons" \
+ icons/*.png
+ install -v -Dm644 -t "$pkgdir/usr/share/licenses/${pkgname}" \
+ LICENSE
+ install -v -Dm644 -t "$pkgdir/usr/share/doc/${pkgname}" \
+ README.md
+}