summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2019-02-23 14:45:04 +0800
committerwenLiangcan2019-02-23 14:45:04 +0800
commit6955da67923447593f2782616626ace3e4244cd4 (patch)
tree76620953ab27b60fc3f8c413d268c08f24353682
downloadaur-6955da67923447593f2782616626ace3e4244cd4.tar.gz
Init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
-rw-r--r--grub2-theme-vimix-git.install14
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..341213b145af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sat Feb 23 06:44:48 UTC 2019
+pkgbase = grub2-theme-vimix-legacy-git
+ pkgdesc = Grub2 theme Vimix (legacy version)
+ pkgver = 20181108
+ pkgrel = 1
+ url = https://github.com/Se7endAY/grub2-theme-vimix
+ install = grub2-theme-vimix-git.install
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = grub
+ provides = grub2-theme-vimix-git
+ provides = grub2-theme-vimix
+ conflicts = grub2-theme-vimix
+ conflicts = grub2-theme-vimix-git
+ replaces = grub2-theme-vimix-git
+ replaces = grub2-theme-vimix
+ source = grub2-theme-vimix-git::git+https://github.com/Se7endAY/grub2-theme-vimix#branch=legacy
+ md5sums = SKIP
+
+pkgname = grub2-theme-vimix-legacy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7afc3928ee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+# Contributor: se7enday(87635645#qq.com)
+
+pkgname=grub2-theme-vimix-legacy-git
+_pkgname=grub2-theme-vimix-git
+pkgver=20181108
+pkgrel=1
+pkgdesc="Grub2 theme Vimix (legacy version)"
+url="https://github.com/Se7endAY/grub2-theme-vimix"
+arch=('any')
+license=('GPLv3')
+depends=('grub')
+makedepends=('git')
+install=${_pkgname}.install
+source=("${_pkgname}"::"git+https://github.com/Se7endAY/grub2-theme-vimix#branch=legacy")
+conflicts=('grub2-theme-vimix' 'grub2-theme-vimix-git')
+replaces=('grub2-theme-vimix-git' 'grub2-theme-vimix')
+provides=('grub2-theme-vimix-git' 'grub2-theme-vimix')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ find ./Vimix/ -type f -exec install -Dm644 {} \
+ "${pkgdir}/boot/grub/themes/{}" \;
+}
+
diff --git a/grub2-theme-vimix-git.install b/grub2-theme-vimix-git.install
new file mode 100644
index 000000000000..1f3f48f47847
--- /dev/null
+++ b/grub2-theme-vimix-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ cat << _EOF
+
+==> Author: 浣衣尘(http://tieba.baidu.com/p/3757812932)
+==> Installation:
+==> Edit /etc/default/grub: GRUB_THEME="/boot/grub/themes/Vimix/theme.txt"
+==> Update grub:# grub-mkconfig -o /boot/grub/grub.cfg
+
+_EOF
+}
+
+post_upgrade() {
+ post_install $1
+}