summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commit1af818173b55cd54e19abbb5f4e75802588f3bc8 (patch)
treeb3a364c22ee80a03995b70ada026f628ac7a3383
parentc1d6e3d8c6048f6724765346bef4f7d1f2e55c7f (diff)
downloadaur-grumpy.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d922edcde124..96acab7bc12f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Jan 20 10:16:51 UTC 2017
+# Wed Mar 27 09:15:58 UTC 2019
pkgbase = grumpy
- pkgdesc = Grumpy is a Python to Go source code transcompiler and runtime
- pkgver = 0.aa58aa68
- pkgrel = 1
+ pkgdesc = Python to Go transpiler and Python interpreter
+ pkgver = 0.1
+ pkgrel = 3
url = https://github.com/google/grumpy
arch = x86_64
- arch = i686
license = Apache
- makedepends = go
- makedepends = python2
+ makedepends = go-pie
makedepends = git
- depends = go
depends = python2
options = !strip
- source = git+https://github.com/google/grumpy.git#commit=aa58aa68
+ source = git+https://github.com/google/grumpy.git#commit=2c8ff4b377ebb6455cf81ef8b7a4ec6cd435ed61
md5sums = SKIP
pkgname = grumpy
diff --git a/PKGBUILD b/PKGBUILD
index 769b75572723..5518d926bd78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,33 @@
-# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Maintainer:
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=grumpy
-pkgver=0.aa58aa68
-pkgrel=1
-pkgdesc='Grumpy is a Python to Go source code transcompiler and runtime'
-arch=('x86_64' 'i686')
-url='https://github.com/google/grumpy'
-depends=('go' 'python2')
-makedepends=('go' 'python2' 'git')
+pkgver=0.1
+pkgrel=3
+pkgdesc='Python to Go transpiler and Python interpreter'
+arch=('x86_64')
license=('Apache')
+url='https://github.com/google/grumpy'
options=('!strip')
-source=("git+https://github.com/google/grumpy.git#commit=${pkgver#*.}")
+depends=('python2')
+makedepends=('go-pie' 'git')
+optdepend=('go: compile sources with Go'
+ 'go-pie: compile sources with Go (PIE)'
+ 'gcc-go: compile sources with gcc-go')
+source=("git+https://github.com/google/grumpy.git#commit=2c8ff4b377ebb6455cf81ef8b7a4ec6cd435ed61")
md5sums=('SKIP')
+prepare() {
+ # https://github.com/google/grumpy/issues/378
+ find "$srcdir" -type f -name "*.go" -exec sed -i 's:const _ =:const _x =:g' '{}' \;
+}
+
build() {
- make -C grumpy -j2
+ make -C grumpy
}
package() {
DESTDIR="$pkgdir" make -C grumpy install
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: