summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-01-20 11:17:19 +0100
committerAlexander F Rødseth2017-01-20 11:17:19 +0100
commitc1d6e3d8c6048f6724765346bef4f7d1f2e55c7f (patch)
treee6ebbbe61fc5b72de41bad88b6573cd131c77b91
parent912a52e0bc45989fb5202df834cdecf9bf155919 (diff)
downloadaur-c1d6e3d8c6048f6724765346bef4f7d1f2e55c7f.tar.gz
Using the new make install section
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--makefile.patch24
3 files changed, 8 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 229bd7b60003..d922edcde124 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 18 15:03:58 UTC 2017
+# Fri Jan 20 10:16:51 UTC 2017
pkgbase = grumpy
pkgdesc = Grumpy is a Python to Go source code transcompiler and runtime
- pkgver = r149.35d1202
+ pkgver = 0.aa58aa68
pkgrel = 1
url = https://github.com/google/grumpy
arch = x86_64
@@ -14,10 +14,8 @@ pkgbase = grumpy
depends = go
depends = python2
options = !strip
- source = git+https://github.com/google/grumpy.git#commit=35d1202
- source = makefile.patch
+ source = git+https://github.com/google/grumpy.git#commit=aa58aa68
md5sums = SKIP
- md5sums = 1a73c49f15cd1ab978e5cacd0ea84ecb
pkgname = grumpy
diff --git a/PKGBUILD b/PKGBUILD
index ce2f15d2ebe1..769b75572723 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=grumpy
-pkgver=r149.35d1202
+pkgver=0.aa58aa68
pkgrel=1
pkgdesc='Grumpy is a Python to Go source code transcompiler and runtime'
arch=('x86_64' 'i686')
@@ -10,22 +10,15 @@ depends=('go' 'python2')
makedepends=('go' 'python2' 'git')
license=('Apache')
options=('!strip')
-source=("git+https://github.com/google/grumpy.git#commit=35d1202"
- 'makefile.patch')
-md5sums=('SKIP'
- '1a73c49f15cd1ab978e5cacd0ea84ecb')
-
-prepare() {
- cd grumpy
- patch -p1 -i ../makefile.patch
-}
+source=("git+https://github.com/google/grumpy.git#commit=${pkgver#*.}")
+md5sums=('SKIP')
build() {
- PYTHON=python2 make -C grumpy -j2
+ make -C grumpy -j2
}
package() {
- PYTHON=python2 DESTDIR="$pkgdir" make -C grumpy install
+ DESTDIR="$pkgdir" make -C grumpy install
}
# vim:set ts=2 sw=2 et:
diff --git a/makefile.patch b/makefile.patch
deleted file mode 100644
index d3d1824ba1fb..000000000000
--- a/makefile.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 100c00f..7a7fd38 100644
---- a/Makefile
-+++ b/Makefile
-@@ -227,3 +227,19 @@ $(patsubst %,build/%.go,$(BENCHMARKS)): build/%.go: %.py $(COMPILER)
- $(BENCHMARK_BINS): build/benchmarks/%_benchmark: build/benchmarks/%.go $(RUNTIME) $(STDLIB)
- @mkdir -p $(@D)
- @go build -o $@ $<
-+
-+# ------------------------------------------------------------------------------
-+# Installation
-+# ------------------------------------------------------------------------------
-+
-+install:
-+ install -d $(DESTDIR)/usr/lib/go
-+ install -d $(DESTDIR)/usr/bin
-+ install -Dm755 tools/benchcmp $(DESTDIR)/usr/bin/benchcmp
-+ install -Dm755 tools/coverparse $(DESTDIR)/usr/bin/coverparse
-+ install -Dm755 tools/diffrange $(DESTDIR)/usr/bin/diffrange
-+ install -Dm755 tools/grumpc $(DESTDIR)/usr/bin/grumpc
-+ install -Dm755 tools/grumprun $(DESTDIR)/usr/bin/grumprun
-+ cp -rv --no-preserve=ownership build/bin build/lib $(DESTDIR)/usr/
-+ cp -rv --no-preserve=ownership build/pkg build/src $(DESTDIR)/usr/lib/go/
-+