summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-14 08:53:40 -0400
committerSolomon Choina2018-06-14 08:53:40 -0400
commit10f031a4a735e7f68b4a2effaf29939b08ac8c93 (patch)
tree97f8841366c62b577746cff21dd5250492a37c53
downloadaur-10f031a4a735e7f68b4a2effaf29939b08ac8c93.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79ef3605183b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = grumpy-irc-git
+ pkgdesc = Modern, yet oldschool IRC client with distributed core, written in C++
+ pkgver = v1.0.0.alpha.r205.g61d441a
+ pkgrel = 1
+ url = https://github.com/grumpy-irc/grumpy
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = unzip
+ makedepends = cmake
+ makedepends = git
+ depends = qt5-base
+ provides = grump-irc
+ provides = libircclient
+ conflicts = grumpy-irc
+ conflicts = libircclient
+ source = grumpy-irc::git+https://github.com/grumpy-irc/grumpy
+ source = https://patch-diff.githubusercontent.com/raw/grumpy-irc/libgp/pull/1.diff
+ sha256sums = SKIP
+ sha256sums = 74ba86bd7e648d8680708636488aea77e9f7313af1f5780d8292a3618e29b1c3
+
+pkgname = grumpy-irc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c6a4d226956
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+pkgname=grumpy-irc-git
+_pkgname=grumpy-irc
+pkgver=v1.0.0.alpha.r205.g61d441a
+pkgrel=1
+pkgdesc="Modern, yet oldschool IRC client with distributed core, written in C++"
+arch=('i686' 'x86_64')
+url="https://github.com/grumpy-irc/grumpy"
+license=('LGPL3')
+depends=('qt5-base')
+makedepends=('unzip' 'cmake' 'git')
+conflicts=('grumpy-irc' 'libircclient')
+provides=('grump-irc' 'libircclient')
+source=("$_pkgname::git+$url" "https://patch-diff.githubusercontent.com/raw/grumpy-irc/libgp/pull/1.diff")
+sha256sums=('SKIP'
+ '74ba86bd7e648d8680708636488aea77e9f7313af1f5780d8292a3618e29b1c3')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ cd "$srcdir/$_pkgname"
+ git submodule update --init --recursive
+ rm -rf build
+ mkdir build
+ cd src/sqlite
+ unzip sqlite-amalgamation-3220000.zip
+ mv sqlite-amalgamation-3220000/* .
+ cd $srcdir/$_pkgname/src/libgp
+ patch -Np1 -i $srcdir/1.diff
+}
+
+build() {
+
+ cd "$srcdir/$_pkgname"
+ cd build
+ cmake ../src \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make -C build DESTDIR="$pkgdir" install
+}