summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Bertin2023-10-22 22:31:21 +0200
committerAntoine Bertin2023-10-22 22:31:21 +0200
commitf64f456f4fead956ea909e225bd36fbde4dcc8aa (patch)
tree1555c879972a705ae37745fa0ea6899a30d83bbd
downloadaur-f64f456f4fead956ea909e225bd36fbde4dcc8aa.tar.gz
feat: first version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a152dbfd984a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gruvbox-plus-icon-theme-git
+ pkgdesc = Icon theme based on Gruvbox color scheme
+ pkgver = 4.0.r680.g812b197
+ pkgrel = 1
+ url = https://github.com/SylEleuth/gruvbox-plus-icon-pack
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = fd
+ depends = gtk-update-icon-cache
+ provides = gruvbox-plus-icon-theme
+ options = !strip
+ options = !emptydirs
+ source = gruvbox-plus-icon-theme-git::git+https://github.com/SylEleuth/gruvbox-plus-icon-pack
+ sha256sums = SKIP
+
+pkgname = gruvbox-plus-icon-theme-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f15c1ce2d626
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Antoine Bertin <antoine.bertin@archlinux.org>
+
+pkgname=gruvbox-plus-icon-theme-git
+pkgver=4.0.r680.g812b197
+pkgrel=1
+pkgdesc="Icon theme based on Gruvbox color scheme"
+arch=(any)
+url=https://github.com/SylEleuth/gruvbox-plus-icon-pack
+license=(GPL3)
+depends=('gtk-update-icon-cache')
+makedepends=('git' 'fd')
+provides=(gruvbox-plus-icon-theme)
+conflicts=()
+options=(!strip !emptydirs)
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname/Gruvbox-Plus-Dark"
+ # remove files with whitespaces as it messes up gtk-update-icon-cache
+ fd '.*\s[^/]*' -X rm {}
+ # remove cache as it will be generated again
+ rm icon-theme.cache
+ install -d "$pkgdir/usr/share/icons"
+ cp -r ./ "$pkgdir/usr/share/icons/Gruvbox-Plus-Dark"
+}
+