summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2017-10-23 19:05:52 +0200
committerneodarz2017-10-23 19:12:47 +0200
commite5293b98cbd3b13faef730afb218c970e33b69a7 (patch)
treee35aa7e414b7fbc9d817880fe59e0501ea641dd1
downloadaur-e5293b98cbd3b13faef730afb218c970e33b69a7.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1393cb528021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = grv
+ pkgdesc = terminal interface for viewing git repositories
+ pkgver = r212.7e00d05
+ pkgrel = 1
+ url = https://github.com/rgburke/grv
+ arch = i686
+ arch = x86_64
+ license = GPL-3.0
+ makedepends = cmake
+ makedepends = go
+ depends = ncurses
+ depends = readline
+ depends = curl
+ provides = grv
+ conflicts = grv
+ source = grv::git+https://github.com/rgburke/grv.git
+ md5sums = SKIP
+
+pkgname = grv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5acdf6f6d65e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: neodarz <neodarz@neodarz.net>
+
+pkgname=grv
+pkgver=r212.7e00d05
+pkgrel=1
+pkgdesc="terminal interface for viewing git repositories"
+arch=('i686' 'x86_64')
+url="https://github.com/rgburke/$pkgname"
+license=('GPL-3.0')
+depends=(ncurses readline curl)
+makedepends=(cmake go)
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("$pkgname"::"git+https://github.com/rgburke/$pkgname.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ export GOROOT=/usr/lib/go
+ export GOPATH="$srcdir"
+ go get -d github.com/rgburke/grv/cmd/grv
+ cd $GOPATH/src/github.com/rgburke/grv
+ make
+}
+
+package() {
+ export GOROOT="$GOPATH"
+ install -Dm755 "$(pwd)/src/github.com/rgburke/grv/grv" "$pkgdir/usr/bin/$pkgname"
+}
+