summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2018-07-11 00:39:02 +0200
committerneodarz2018-07-11 00:39:02 +0200
commita9a07ca6b3fa1ee75ec14cf09c6389572bd70c33 (patch)
tree44b77540906ce25d6b5bac54771577c3b7ab947a
parente57f02dfa74ba3906de9bf08b95833128e369a58 (diff)
downloadaur-grv-git.tar.gz
Fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c514a29ccd72..f94479ef5bc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grv-git
pkgdesc = terminal interface for viewing git repositories
- pkgver = r229.121ee06
+ pkgver = v0.2.0.r11.g7ed2346
pkgrel = 1
url = https://github.com/rgburke/grv
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index f744f00e66f8..967e3cebc5b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=grv
pkgname=$_pkgname-git
-pkgver=r229.121ee06
+pkgver=v0.2.0.r11.g7ed2346
pkgrel=1
pkgdesc="terminal interface for viewing git repositories"
arch=('i686' 'x86_64')
@@ -25,15 +25,18 @@ pkgver() {
}
build() {
- export GOROOT=/usr/lib/go
export GOPATH="$srcdir"
- go get -d github.com/rgburke/grv/cmd/$_pkgname
+ mkdir -p $GOPATH/src/github.com/rgburke
+ rm -rf $GOPATH/src/github.com/rgburke/$_pkgname
+ mv $srcdir/$_pkgname $GOPATH/src/github.com/rgburke
+
cd $GOPATH/src/github.com/rgburke/$_pkgname
make
}
package() {
- export GOROOT="$GOPATH"
+ # Make instal doesn't work :'(
+ #make install
install -Dm755 "$srcdir/src/github.com/rgburke/grv/grv" "$pkgdir/usr/bin/$_pkgname"
}