summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhvalera2024-02-12 19:22:59 +0200
committerkhvalera2024-02-12 19:22:59 +0200
commit63b9065f0b6bdb6760a3ef9158aa596040d4d50a (patch)
tree23edeaba6c181a9f88ec038f772b670ee3f66cfd
parentaf5959a464bd39a7f1bbdbf547b3177aa6e9728d (diff)
downloadaur-63b9065f0b6bdb6760a3ef9158aa596040d4d50a.tar.gz
v1.4.1
-rw-r--r--.SRCINFO7
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD10
3 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a65e2ea7b336..2fb2b4432bfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gsender
pkgdesc = Connect to and control Grbl-based CNCs
- pkgver = 1.2.2
+ pkgver = 1.4.1
pkgrel = 1
url = https://github.com/Sienci-Labs/gsender
arch = x86_64
@@ -8,8 +8,9 @@ pkgbase = gsender
makedepends = npm
makedepends = yarn
makedepends = libxcrypt-compat
+ makedepends = debugedit
depends = nodejs
- source = https://github.com/Sienci-Labs/gsender/archive/v1.2.2.tar.gz
- sha512sums = c4e07887825dda4b4d4a289ee6551c1d80026fa0ddc2f45b9312dce241fee0273ee6ac49a31a378e6f29d3189a2f2caad1b30cbcc9ea49e6ff4ddef8a80317e2
+ source = https://github.com/Sienci-Labs/gsender/archive/v1.4.1.tar.gz
+ sha512sums = 277de6392bcad87968dd8b28b7812f001a2423f630becda8fcc70d070d7d980fd0f43fa308bae754d1af585af4181e868d0e92a141aea688a72ac4b6c8a4bd3c
pkgname = gsender
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 3c015518aa94..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,7 +0,0 @@
-Copyright (C) 2023 Sienci Labs Inc.
-
-gSender is free software: you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation, under version 3 of the License.
-
-You should have received a copy of the GNU General Public License along with gSender. If not, see <https://www.gnu.org/licenses/>.
-
-This software is provided "as is", without any warranty, express or implied, of any nature, and you use the software at your own risk. In no event shall any author or copyright holder be liable for any claim, damages or other liability, whether in an action of contract, tort or otherwise, arising from, out of or in connection with the software or the use or other dealings in the software.
diff --git a/PKGBUILD b/PKGBUILD
index 404e2bdb2298..7e8daed65eb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: khvalera <khvalera@ukr.net>
pkgname=gsender
-pkgver=1.2.2
+pkgver=1.4.1
pkgrel=1
pkgdesc="Connect to and control Grbl-based CNCs"
arch=("x86_64")
url="https://github.com/Sienci-Labs/${pkgname}"
license=('MIT')
depends=('nodejs')
-makedepends=('npm' 'yarn' 'libxcrypt-compat')
+makedepends=('npm' 'yarn' 'libxcrypt-compat' 'debugedit')
source=("https://github.com/Sienci-Labs/${pkgname}/archive/v$pkgver.tar.gz")
-sha512sums=('c4e07887825dda4b4d4a289ee6551c1d80026fa0ddc2f45b9312dce241fee0273ee6ac49a31a378e6f29d3189a2f2caad1b30cbcc9ea49e6ff4ddef8a80317e2')
+sha512sums=('277de6392bcad87968dd8b28b7812f001a2423f630becda8fcc70d070d7d980fd0f43fa308bae754d1af585af4181e868d0e92a141aea688a72ac4b6c8a4bd3c')
build() {
cd "$pkgname-$pkgver"
sed -i 's/"AppImage",//' package.json
- export NODE_OPTIONS=--openssl-legacy-provider
+ export NODE_OPTIONS="--openssl-legacy-provider --max-old-space-size=4096"
yarn install
yarn build-prod
yarn build:linux-x64
@@ -26,7 +26,5 @@ package() {
install -d "${pkgdir}/opt/gSender"
cp -dr --no-preserve=ownership ./output/linux-unpacked/* "${pkgdir}"/opt/gSender/
ln -sf '/opt/gSender/gsender' "${pkgdir}/usr/bin/gsender"
- ar -p ./output/gSender_1.2.2_amd64.deb data.tar.xz | tar Jx -C .
- cp -dr --no-preserve=ownership ./usr "${pkgdir}"/
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}