summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhvalera2023-07-17 17:11:55 +0300
committerkhvalera2023-07-17 17:11:55 +0300
commitaf5959a464bd39a7f1bbdbf547b3177aa6e9728d (patch)
tree255e50ec4b891a1b7f405185f964353a5187ce56
downloadaur-af5959a464bd39a7f1bbdbf547b3177aa6e9728d.tar.gz
add gsender
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD32
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a65e2ea7b336
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gsender
+ pkgdesc = Connect to and control Grbl-based CNCs
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/Sienci-Labs/gsender
+ arch = x86_64
+ license = MIT
+ makedepends = npm
+ makedepends = yarn
+ makedepends = libxcrypt-compat
+ depends = nodejs
+ source = https://github.com/Sienci-Labs/gsender/archive/v1.2.2.tar.gz
+ sha512sums = c4e07887825dda4b4d4a289ee6551c1d80026fa0ddc2f45b9312dce241fee0273ee6ac49a31a378e6f29d3189a2f2caad1b30cbcc9ea49e6ff4ddef8a80317e2
+
+pkgname = gsender
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3c015518aa94
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+Copyright (C) 2023 Sienci Labs Inc.
+
+gSender is free software: you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation, under version 3 of the License.
+
+You should have received a copy of the GNU General Public License along with gSender. If not, see <https://www.gnu.org/licenses/>.
+
+This software is provided "as is", without any warranty, express or implied, of any nature, and you use the software at your own risk. In no event shall any author or copyright holder be liable for any claim, damages or other liability, whether in an action of contract, tort or otherwise, arising from, out of or in connection with the software or the use or other dealings in the software.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..404e2bdb2298
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: khvalera <khvalera@ukr.net>
+pkgname=gsender
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Connect to and control Grbl-based CNCs"
+arch=("x86_64")
+url="https://github.com/Sienci-Labs/${pkgname}"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm' 'yarn' 'libxcrypt-compat')
+source=("https://github.com/Sienci-Labs/${pkgname}/archive/v$pkgver.tar.gz")
+sha512sums=('c4e07887825dda4b4d4a289ee6551c1d80026fa0ddc2f45b9312dce241fee0273ee6ac49a31a378e6f29d3189a2f2caad1b30cbcc9ea49e6ff4ddef8a80317e2')
+
+build() {
+ cd "$pkgname-$pkgver"
+ sed -i 's/"AppImage",//' package.json
+ export NODE_OPTIONS=--openssl-legacy-provider
+ yarn install
+ yarn build-prod
+ yarn build:linux-x64
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/opt/gSender"
+ cp -dr --no-preserve=ownership ./output/linux-unpacked/* "${pkgdir}"/opt/gSender/
+ ln -sf '/opt/gSender/gsender' "${pkgdir}/usr/bin/gsender"
+ ar -p ./output/gSender_1.2.2_amd64.deb data.tar.xz | tar Jx -C .
+ cp -dr --no-preserve=ownership ./usr "${pkgdir}"/
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}