summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:54:59 +0200
committerLubosz Sarnecki2015-06-22 22:54:59 +0200
commit40d4212aa71bfc98597886ba3b73d19ff08ab836 (patch)
tree13edce6a1a7b362771f50a87893bb82715011d32
downloadaur-40d4212aa71bfc98597886ba3b73d19ff08ab836.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD39
-rwxr-xr-xgsettings-desktop-schemas.install14
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8fcf36d32c74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gsettings-desktop-schemas-git
+ pkgdesc = Shared GSettings schemas for the desktop
+ pkgver = 3.8.0.5.gca797db
+ pkgrel = 1
+ url = http://live.gnome.org/
+ install = gsettings-desktop-schemas.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glib2-git
+ depends = intltool
+ provides = gsettings-desktop-schemas
+ conflicts = gsettings-desktop-schemas
+ options = makeflags
+ options = !emptydirs
+ source = git://git.gnome.org/gsettings-desktop-schemas
+ sha256sums = SKIP
+
+pkgname = gsettings-desktop-schemas-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4ae502955f58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+#Maintainer: Lubosz <lubosz@gmail.com>
+#Contributor: helq <linuxero789@gmail.com>
+
+pkgname=gsettings-desktop-schemas-git
+_realpkgname=gsettings-desktop-schemas
+pkgver=3.8.0.5.gca797db
+pkgrel=1
+pkgdesc="Shared GSettings schemas for the desktop"
+arch=(i686 x86_64)
+url="http://live.gnome.org/"
+license=('GPL')
+depends=('glib2-git' 'intltool')
+makedepends=('git')
+options=(makeflags !emptydirs)
+
+provides=("${_realpkgname}")
+conflicts=("${_realpkgname}")
+
+source="git://git.gnome.org/gsettings-desktop-schemas"
+sha256sums=('SKIP')
+
+_gitname="gsettings-desktop-schemas"
+install=gsettings-desktop-schemas.install
+
+pkgver() {
+ cd $_gitname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR=$pkgdir install || return 1
+}
diff --git a/gsettings-desktop-schemas.install b/gsettings-desktop-schemas.install
new file mode 100755
index 000000000000..3830fd4bf483
--- /dev/null
+++ b/gsettings-desktop-schemas.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo "Recompiling schemas."
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ echo "Recompiling schemas."
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_remove() {
+ echo "Recompiling schemas."
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}