summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjunglerobba2019-01-12 18:34:30 +0100
committerjunglerobba2019-01-12 18:34:30 +0100
commit918e75e347f19ec9aca477286de64b149b0aa886 (patch)
tree64717e6a7112af09819b3cf41c02a108bd771b53
parent5607d9853537dfb61f80d55ce13ef5d47cad196e (diff)
downloadaur-918e75e347f19ec9aca477286de64b149b0aa886.tar.gz
patch for meson build
-rw-r--r--.SRCINFO4
-rw-r--r--12.patch58
-rwxr-xr-xPKGBUILD15
3 files changed, 73 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1746c25206c4..091ff619769d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,12 +9,14 @@ pkgbase = gsettings-desktop-schemas-dev
makedepends = git
makedepends = meson
makedepends = gobject-introspection
- depends = glib2-git
+ depends = glib2
depends = intltool
provides = gsettings-desktop-schemas
conflicts = gsettings-desktop-schemas
source = git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#tag=3.31.0.1
+ source = 12.patch
sha256sums = SKIP
+ sha256sums = fefcf993c0908ab53bcb4ad1cf4f46b8bd99c71d588c6117b1f16993d2250424
pkgname = gsettings-desktop-schemas-dev
diff --git a/12.patch b/12.patch
new file mode 100644
index 000000000000..3c300b36376d
--- /dev/null
+++ b/12.patch
@@ -0,0 +1,58 @@
+From 524fee120765fb43a141c3109bb39cadd7fb79fc Mon Sep 17 00:00:00 2001
+From: Carlos Garnacho <carlosg@gnome.org>
+Date: Fri, 11 Jan 2019 14:18:01 +0100
+Subject: [PATCH] meson: Generate and install org.gnome.desktop.enums.xml file
+
+We were failing to generate it on meson. Avoid gnome.mkenums() since it
+becomes rather awkward to use (optimized for c/h files output). Probably
+worth revisiting if https://github.com/mesonbuild/meson/issues/1687 gets
+better.
+
+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas/issues/6
+---
+ headers/meson.build | 15 +++++++++++++++
+ meson.build | 2 ++
+ 2 files changed, 17 insertions(+)
+
+diff --git a/headers/meson.build b/headers/meson.build
+index f80f2bb..3ce8b61 100644
+--- a/headers/meson.build
++++ b/headers/meson.build
+@@ -4,6 +4,21 @@ headers = files(
+
+ install_headers(headers, subdir: gsettings_desktop_schemas_name)
+
++enums_xml = custom_target(
++ 'org.gnome.desktop.enums.xml',
++ input: headers,
++ output: 'org.gnome.desktop.enums.xml',
++ command: [glib_mkenums,
++ '--comments', '<!-- @comment@ -->',
++ '--fhead', '<schemalist>',
++ '--vhead', '<@type@ id="org.gnome.desktop.@EnumName@">',
++ '--vprod', ' <value nick="@valuenick@" value="@valuenum@"/>',
++ '--vtail', ' </@type@>',
++ '--ftail', '</schemalist>', '@INPUT@'],
++ capture: true,
++ install: true,
++ install_dir: schemasdir)
++
+ if not meson.is_cross_build() and get_option('introspection')
+ noinst_lib = shared_library('noinst',
+ headers,
+diff --git a/meson.build b/meson.build
+index 057c569..cc577b4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -37,6 +37,8 @@ pkg.generate(name: gsettings_desktop_schemas_name,
+ version: gsettings_desktop_schemas_version,
+ description: 'Shared GSettings schemas for the desktop, including helper headers')
+
++glib_mkenums = find_program('glib-mkenums')
++
+ subdir('headers')
+ subdir('schemas')
+ subdir('po')
+--
+2.18.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 4d902756ccbd..fe8128d1d7db 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,23 @@ pkgdesc="Shared GSettings schemas for the desktop"
arch=(i686 x86_64)
url="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
license=('GPL')
-depends=(glib2-git intltool)
+depends=(glib2 intltool)
makedepends=(git meson gobject-introspection)
provides=("${_realpkgname}")
conflicts=("${_realpkgname}")
-source=("git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#tag=${pkgver}")
-sha256sums=('SKIP')
+source=("git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#tag=${pkgver}"
+ "12.patch")
+sha256sums=('SKIP'
+ 'fefcf993c0908ab53bcb4ad1cf4f46b8bd99c71d588c6117b1f16993d2250424')
+
+prepare() {
+ cd ${_realpkgname}
+
+ #https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas/merge_requests/12
+ git apply -3 ../12.patch
+}
build() {
arch-meson gsettings-desktop-schemas build