summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2020-06-07 23:00:45 +0200
committerKevin Majewski2020-06-07 23:00:45 +0200
commit92cfeafaeae25a9a2cdd4d591850c254d01e8453 (patch)
treec57821f19d20342a22df60d2c76e4ae2113a06da
parent6200f923b05caab38409201a95af7922da2c2ce5 (diff)
downloadaur-92cfeafaeae25a9a2cdd4d591850c254d01e8453.tar.gz
3.36.1-1
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD38
2 files changed, 26 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a16f399bc2c..f674757bcd44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = gsettings-desktop-schemas-dev
pkgdesc = Shared GSettings schemas for the desktop
- pkgver = 3.33.0
+ pkgver = 3.36.1
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas
- arch = x86_64
+ arch = any
license = GPL
+ makedepends = gobject-introspection
makedepends = git
makedepends = meson
- makedepends = gobject-introspection
depends = glib2
- depends = intltool
- optdepends = adobe-source-code-pro-fonts: default monospace font
- provides = gsettings-desktop-schemas
- conflicts = gsettings-desktop-schemas
- source = git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#tag=3.33.0
- sha256sums = SKIP
+ depends = dconf
+ depends = cantarell-fonts
+ depends = adobe-source-code-pro-fonts
+ source = git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#commit=4f18b55461a92488722a0209bdacbd6a6a1d1bdd
+ sha512sums = SKIP
pkgname = gsettings-desktop-schemas-dev
diff --git a/PKGBUILD b/PKGBUILD
index 8be8a0bcdd98..d064a65a6eb8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,31 @@
-#Maintainer: junglerobba <tobias.langendorf@gmail.com>
-#Contributor: Lubosz <lubosz@gmail.com>
-#Contributor: helq <linuxero789@gmail.com>
-
-
pkgname=gsettings-desktop-schemas-dev
-_realpkgname=gsettings-desktop-schemas
-pkgver=3.33.0
+_pkgname=gsettings-desktop-schemas
+pkgver=3.36.1
pkgrel=1
pkgdesc="Shared GSettings schemas for the desktop"
-arch=(x86_64)
+arch=(any)
url="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
-license=('GPL')
-depends=(glib2 intltool)
-optdepends=(
- 'adobe-source-code-pro-fonts: default monospace font'
-)
-makedepends=(git meson gobject-introspection)
-
-provides=("${_realpkgname}")
-conflicts=("${_realpkgname}")
+license=(GPL)
+depends=('glib2' 'dconf' 'cantarell-fonts' 'adobe-source-code-pro-fonts')
+makedepends=('gobject-introspection' 'git' 'meson')
+_commit=4f18b55461a92488722a0209bdacbd6a6a1d1bdd # tags/3.36.1^0
+source=("git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#commit=$_commit")
+sha512sums=('SKIP')
-source=("git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#tag=${pkgver}")
-sha256sums=('SKIP')
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
build() {
- arch-meson gsettings-desktop-schemas build
+ arch-meson $_pkgname build
ninja -C build
}
+check() {
+ meson test -C build --print-errorlogs
+}
+
package() {
DESTDIR="$pkgdir" meson install -C build
}