summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-23 22:01:54 +0200
committerPellegrino Prevete2023-06-23 22:01:54 +0200
commit46931d6efb7dd6c713494deecd6c76d4a6a2ea9f (patch)
treed7edf060faafc614eb14b8e189e8f085e2efcc3d
parente8042a4635a01e939c26329b40b213451f0f61a0 (diff)
downloadaur-46931d6efb7dd6c713494deecd6c76d4a6a2ea9f.tar.gz
bump pkgver, parameterize
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 231df9f4b2e3..a8077811a731 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gsettings-desktop-schemas-git
pkgdesc = Shared GSettings schemas for the desktop
- pkgver = 43.0.r2.g0083a8e
+ pkgver = 44.0.r6.g3e99898
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas
arch = any
@@ -12,9 +12,9 @@ pkgbase = gsettings-desktop-schemas-git
depends = dconf
depends = cantarell-fonts
depends = adobe-source-code-pro-fonts
- provides = gsettings-desktop-schemas=43.0.r2.g0083a8e
+ provides = gsettings-desktop-schemas=44.0.r6.g3e99898
conflicts = gsettings-desktop-schemas
- source = git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git
+ source = git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas
sha256sums = SKIP
pkgname = gsettings-desktop-schemas-git
diff --git a/PKGBUILD b/PKGBUILD
index f5407270686a..d3ef4c1eb82f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,32 +6,37 @@
# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
# Contributor: Andrey Vetrov <vetrov at mail dot ru>
-pkgname=gsettings-desktop-schemas-git
-pkgver=43.0.r2.g0083a8e
+_pkgname="gsettings-desktop-schemas"
+pkgname="${_pkgname}-git"
+pkgver=44.0.r6.g3e99898
pkgrel=1
pkgdesc="Shared GSettings schemas for the desktop"
arch=(any)
-url="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
+url="https://gitlab.gnome.org/GNOME/${_pkgname}"
license=(GPL)
-provides=("gsettings-desktop-schemas=$pkgver")
-conflicts=(gsettings-desktop-schemas)
-depends=(glib2 dconf cantarell-fonts adobe-source-code-pro-fonts)
+provides=("${_pkgname}=$pkgver")
+conflicts=("${_pkgname}")
+depends=(
+ glib2
+ dconf
+ cantarell-fonts
+ adobe-source-code-pro-fonts)
makedepends=(gobject-introspection git meson)
-source=("git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git")
+source=("git+${url}")
sha256sums=('SKIP')
pkgver() {
- cd ${pkgname:0:25}
+ cd ${_pkgname:0:25}
# git describe --tags | sed 's/-/+/g'
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd ${pkgname:0:25}
+ cd ${_pkgname:0:25}
}
build() {
- arch-meson ${pkgname:0:25} build
+ arch-meson ${_pkgname:0:25} build
meson compile -C build
}
@@ -40,5 +45,5 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ DESTDIR="${pkgdir}" meson install -C build
}