summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-08-06 20:34:09 +0200
committerMichael Straube2017-08-06 20:34:09 +0200
commit5a14e08470c633015b472ff329482757fa53f657 (patch)
treeb1dd9db6dc4e1093fab3c68af5c8b25215eb6ae3
parent873152b0c5cda47d3d1637adf841005244008092 (diff)
downloadaur-5a14e08470c633015b472ff329482757fa53f657.tar.gz
Fix build error
Add dependency gnustep-back Symlink desktop entry
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD42
2 files changed, 19 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8edca9d29302..665233bcbbdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = gshisen.app
- pkgdesc = A game for GNUstep.
+ pkgdesc = Shisen-sho puzzle game for GNUstep
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.nongnu.org/gap/gshisen/index.html
arch = i686
arch = x86_64
groups = gnustep
license = GPL
makedepends = gcc-objc
- makedepends = gnustep-make
depends = gnustep-base
depends = gnustep-gui
- source = http://savannah.nongnu.org/download/gap/GShisen-1.3.0.tar.gz
+ depends = gnustep-back
+ source = https://savannah.nongnu.org/download/gap/GShisen-1.3.0.tar.gz
sha256sums = f904621f70cccc2efa70698c21a78049870fb4305775f9a04ecf7f7a7f4a5dfe
pkgname = gshisen.app
diff --git a/PKGBUILD b/PKGBUILD
index 0ffa591555ac..16e018d4f21f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,29 @@
-# Maintainer: Thomas Ascher <thomas.ascher@gmx.at>
+# Maintainer: Michael Straube <straubem@gmx.de>
# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+
pkgname=gshisen.app
-_pkgname=GShisen
-pkgrel=1
+pkgrel=2
pkgver=1.3.0
-pkgdesc="A game for GNUstep."
+pkgdesc='Shisen-sho puzzle game for GNUstep'
arch=('i686' 'x86_64')
-url="http://www.nongnu.org/gap/gshisen/index.html"
+url='http://www.nongnu.org/gap/gshisen/index.html'
license=('GPL')
groups=('gnustep')
-depends=('gnustep-base'
- 'gnustep-gui')
-makedepends=('gcc-objc'
- 'gnustep-make')
-source=("http://savannah.nongnu.org/download/gap/$_pkgname-$pkgver.tar.gz")
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc')
+source=("https://savannah.nongnu.org/download/gap/GShisen-$pkgver.tar.gz")
sha256sums=('f904621f70cccc2efa70698c21a78049870fb4305775f9a04ecf7f7a7f4a5dfe')
build() {
- cd "$_pkgname-$pkgver"
+ cd GShisen-$pkgver
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
make
}
package() {
- cd "$_pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
- install -D -m644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" \
- "$pkgdir/usr/share/applications/$_pkgname.desktop"
-}
-
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
+ cd GShisen-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -d "$pkgdir"/usr/share/applications
+ ln -s /usr/lib/GNUstep/Applications/GShisen.app/Resources/GShisen.desktop \
+ "$pkgdir"/usr/share/applications/GShisen.desktop
}