summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-07-03 11:33:39 +0200
committerMaxime Gauduin2018-07-03 11:33:39 +0200
commit91788adcc38d4290e8fdd736afe25baf22013e21 (patch)
tree63eb45275acf6667c0c1df2d1ec4e501dceab693
downloadaur-91788adcc38d4290e8fdd736afe25baf22013e21.tar.gz
Add gsignond-plugin-lastfm-git
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c48b6ff0c4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Jul 3 09:33:38 UTC 2018
+pkgbase = gsignond-plugin-lastfm-git
+ pkgdesc = LastFM plugin for gSSO
+ pkgver = r3.0a7a5f8
+ pkgrel = 1
+ url = https://gitlab.com/accounts-sso/gsignond-plugin-lastfm
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = gsignond
+ depends = json-glib
+ depends = libsoup
+ provides = gsignond-plugin-lastfm
+ conflicts = gsignond-plugin-lastfm
+ source = git+https://gitlab.com/accounts-sso/gsignond-plugin-lastfm.git
+ sha256sums = SKIP
+
+pkgname = gsignond-plugin-lastfm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8c13fc2a1d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=gsignond-plugin-lastfm-git
+pkgver=r3.0a7a5f8
+pkgrel=1
+pkgdesc='LastFM plugin for gSSO'
+arch=('x86_64')
+url='https://gitlab.com/accounts-sso/gsignond-plugin-lastfm'
+license=('GPL3')
+depends=('gsignond' 'json-glib' 'libsoup')
+makedepends=('git' 'meson' 'vala')
+provides=('gsignond-plugin-lastfm')
+conflicts=('gsignond-plugin-lastfm')
+source=('git+https://gitlab.com/accounts-sso/gsignond-plugin-lastfm.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gsignond-plugin-lastfm
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ arch-meson gsignond-plugin-lastfm build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+
+# vim: ts=2 sw=2 et: