summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-03-25 01:24:15 +0800
committerChocobo12021-03-25 01:25:08 +0800
commit11bc10aa4d7c3bb7f0e700e19fbc245b86260ff0 (patch)
tree0c376d300abb0aa402b3b40d891201969f15445a
downloadaur-11bc10aa4d7c3bb7f0e700e19fbc245b86260ff0.tar.gz
newpkg: gsl-git 2.6.r48.ga0f31bd6-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e43e459d7be5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gsl-git
+ pkgdesc = A numerical library for C and C++
+ pkgver = 2.6.r48.ga0f31bd6
+ pkgrel = 1
+ url = https://www.gnu.org/software/gsl/gsl.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ provides = gsl
+ conflicts = gsl
+ options = staticlibs
+ source = git+https://git.savannah.gnu.org/git/gsl.git
+ sha256sums = SKIP
+
+pkgname = gsl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95ea78565224
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gsl-git
+pkgver=2.6.r48.ga0f31bd6
+pkgrel=1
+pkgdesc="A numerical library for C and C++"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/gsl/gsl.html"
+license=('GPL')
+depends=('glibc')
+makedepends=('git')
+provides=('gsl')
+conflicts=('gsl')
+options=('staticlibs')
+source=("git+https://git.savannah.gnu.org/git/gsl.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "gsl"
+
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "gsl"
+
+ ./autogen.sh
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "gsl"
+
+ make check
+}
+
+package() {
+ cd "gsl"
+
+ make DESTDIR="$pkgdir" install
+}