summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraditya-K22023-05-24 20:31:33 +0530
committeraditya-K22023-05-24 20:31:33 +0530
commit1335b8ba8e791670a294998a94ab8a8b0333f760 (patch)
tree319b741df03ed11e1bcb96f730f8905a632c003e
parentdcab1435bf7ac159e6e81a685a9ab92c34b16539 (diff)
downloadaur-1335b8ba8e791670a294998a94ab8a8b0333f760.tar.gz
Use Makefile to install the package
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98c01af9dd30..a463b599a92f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = gspt-git
pkgdesc = Spotify for Terminal written in Go.
- pkgver = r255.8fbd92e
+ pkgver = r287.29fb830
pkgrel = 1
url = https://github.com/aditya-K2/gspt
arch = x86_64
license = GPL3
makedepends = git
makedepends = go
+ makedepends = make
source = gspt-git::git+https://github.com/aditya-K2/gspt
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c81804ae01e9..b4bad916d515 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=gspt-git
-pkgver=r255.8fbd92e
+pkgver=r287.29fb830
pkgrel=1
pkgdesc='Spotify for Terminal written in Go.'
arch=('x86_64')
url="https://github.com/aditya-K2/gspt"
license=('GPL3')
-makedepends=('git' 'go')
+makedepends=('git' 'go' 'make')
source=("$pkgname::git+$url")
sha256sums=('SKIP')
@@ -19,16 +19,14 @@ pkgver() {
prepare() {
cd "$pkgname"
- mkdir -p build
+ git config --global --add safe.directory "$(pwd)"
}
build() {
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
cd "$pkgname"
- go build -v -o build
}
package() {
cd "$pkgname"
- install -D build/gspt -t "$pkgdir/usr/bin/"
+ sudo make install
}