summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraditya-K22023-05-04 17:50:15 +0530
committeraditya-K22023-05-04 17:50:15 +0530
commitdcab1435bf7ac159e6e81a685a9ab92c34b16539 (patch)
tree6deed7dad67a01de44dc27aaf3579e6496312a2e
downloadaur-dcab1435bf7ac159e6e81a685a9ab92c34b16539.tar.gz
Initial Commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98c01af9dd30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gspt-git
+ pkgdesc = Spotify for Terminal written in Go.
+ pkgver = r255.8fbd92e
+ pkgrel = 1
+ url = https://github.com/aditya-K2/gspt
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ source = gspt-git::git+https://github.com/aditya-K2/gspt
+ sha256sums = SKIP
+
+pkgname = gspt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c81804ae01e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: aditya-K2 <adityakurdunkar2@gmail.com>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=gspt-git
+pkgver=r255.8fbd92e
+pkgrel=1
+pkgdesc='Spotify for Terminal written in Go.'
+arch=('x86_64')
+url="https://github.com/aditya-K2/gspt"
+license=('GPL3')
+makedepends=('git' 'go')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ mkdir -p build
+}
+
+build() {
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ cd "$pkgname"
+ go build -v -o build
+}
+
+package() {
+ cd "$pkgname"
+ install -D build/gspt -t "$pkgdir/usr/bin/"
+}