summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorent Thiéry2017-10-03 15:08:36 +0200
committerFlorent Thiéry2017-10-03 15:08:36 +0200
commit8bca2e271eb2d8caf5afb5da7987f33a48887bdb (patch)
tree2a0d3f2cd18fe489ae86bb2a35a073affe78d3c5
downloadaur-8bca2e271eb2d8caf5afb5da7987f33a48887bdb.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e67894dbf81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Oct 3 13:08:22 UTC 2017
+pkgbase = gst-instruments-git
+ pkgdesc = Set of performance analyzing tools for time profiling and data flow inspection in GStreamer apps.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/kirushyk/gst-instruments
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gstreamer
+ depends = gtk3
+ depends = vala
+ depends = xdot
+ source = git+https://github.com/ribalda/gst-instruments.git#branch=fix29
+ sha512sums = SKIP
+
+pkgname = gst-instruments-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d3280b7fc45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Florent Thiéry fthiery@gmail.com
+pkgname=gst-instruments-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="Set of performance analyzing tools for time profiling and data flow inspection in GStreamer apps."
+arch=('i686' 'x86_64')
+url="https://github.com/kirushyk/gst-instruments"
+license=('GPL3')
+depends=('gstreamer' 'gtk3' 'vala' 'xdot')
+#https://github.com/kirushyk/gst-instruments/issues/29
+#source=('git+https://github.com/kirushyk/gst-instruments.git')
+source=('git+https://github.com/ribalda/gst-instruments.git#branch=fix29')
+sha512sums=('SKIP')
+
+build() {
+ cd gst-instruments
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd gst-instruments
+ make DESTDIR="$pkgdir/" install
+}