summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-15 13:30:00 -0500
committerCarlos Aznarán Laos2022-03-15 13:30:00 -0500
commit63379996de5a33c4dc9f858700383de71e39be1c (patch)
tree09656e80a1bd9814375c8fa979356120d1e9559e
parent90dbe1e16db9c9e54bb9f02c5de045da76421740 (diff)
downloadaur-gst-mpg123.tar.gz
Fix git sources
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD52
2 files changed, 23 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e06aa393cd2f..b87b451316ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = gst-mpg123
- pkgdesc = MP3 decoding for gstreamer-0.10, using the mpg123 library.
+ pkgdesc = MP3 decoding for gstreamer-0.10, using the mpg123 library
pkgver = 20121118
pkgrel = 1
- url = https://github.com/dv1/gstmpg123.git
- arch = i686
- arch = x86_64
+ url = https://github.com/dv1/gstmpg123
+ arch = any
license = LGPL
makedepends = pkgconfig
makedepends = git
depends = gstreamer0.10-base
depends = mpg123
+ depends = python2
pkgname = gst-mpg123
-
diff --git a/PKGBUILD b/PKGBUILD
index f6722a2e1a21..378d6d55e40b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,29 @@
-# Maintainer: Alois Nespor <info at aloisnespor dot info>
-
+# Contributor: Alois Nespor <info at aloisnespor dot info>
pkgname=gst-mpg123
pkgver=20121118
pkgrel=1
-pkgdesc="MP3 decoding for gstreamer-0.10, using the mpg123 library."
-arch=('i686' 'x86_64')
-url="https://github.com/dv1/gstmpg123.git"
-license=('LGPL')
-depends=('gstreamer0.10-base' 'mpg123')
-makedepends=('pkgconfig' 'git')
+pkgdesc="MP3 decoding for gstreamer-0.10, using the mpg123 library"
+arch=(any)
+url="https://github.com/dv1/${pkgname/-/}"
+license=(LGPL)
+depends=(gstreamer0.10-base mpg123 python2)
+makedepends=(pkgconfig git)
-_gitroot="git://github.com/dv1/gstmpg123.git"
-_gitname="gstmpg123"
+prepare() {
+ git clone $url
+ cd ${pkgname/-/}
+ echo "Configuring..."
+ sed -i 's:python:python2:' waf
+ sed -i 's:python:python2:' wscript
+}
build() {
-
- msg "Connecting to the git repository..."
- if [ -d "$srcdir/$_gitname" ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
-
- msg "GIT checkout done or server timeout"
- cd "$srcdir"
- rm -rf $_gitname-build
- git clone $_gitname $_gitname-build
- cd $_gitname-build
-
- msg2 "Configuring..."
- sed -i 's:python:python2:' waf
- sed -i 's:python:python2:' wscript
- ./waf configure build_0_10 --prefix=/usr --disable-gstreamer-1-0
+ cd ${pkgname/-/}
+ ./waf configure build_0_10 --prefix=/usr --disable-gstreamer-1-0
}
-
+
package() {
- cd "$srcdir/$_gitname-build"
- DESTDIR="$pkgdir" ./waf install_0_10
+ cd ${pkgname/-/}
+ DESTDIR="$pkgdir" ./waf install_0_10
}
-