summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMazhar Hussain2023-07-30 08:59:56 +0500
committerMazhar Hussain2023-07-30 08:59:56 +0500
commit58b23e891abdeca098c11c829e3a86479f2838be (patch)
treefc0243b94142b545f414572adf50913103f333a5
parente3b85bd4efcb71e30610febbb5955d7f8f17b20d (diff)
downloadaur-58b23e891abdeca098c11c829e3a86479f2838be.tar.gz
Add check()
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3f9646b70b3..03f035a74ca8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,6 +29,11 @@ build(){
cargo cbuild "${_cargo_opts[@]}"
}
+check() {
+ cd $_reponame-$pkgver
+ cargo ctest "${_cargo_opts[@]}" --target-dir=tests-build
+}
+
package() {
cd $_reponame-$pkgver
cargo cinstall "${_cargo_opts[@]}" --destdir="$pkgdir"