summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-09-11 14:56:18 -0600
committeryochananmarqos2019-09-11 14:56:18 -0600
commit2665897318dc770f8e33040c2d1c8bbf49f80d59 (patch)
treea16b44926077e9c08a8f5eb22330af6b9bc7a6f8
downloadaur-2665897318dc770f8e33040c2d1c8bbf49f80d59.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--gst-plugin-jamesdsp.install8
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1db76de8ed20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gst-plugin-jamesdsp-git
+ pkgdesc = JamesDSP wrapper plugin for GStreamer
+ pkgver = r14.378f0fa
+ pkgrel = 1
+ url = https://github.com/ThePBone/gst-plugin-jamesdsp
+ install = gst-plugin-jamesdsp.install
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = gst-plugins-base-libs
+ provides = gst-plugin-jamesdsp
+ conflicts = gst-plugin-jamesdsp
+ conflicts = gst-plugin-viper4linux
+ conflicts = gst-plugin-viperfx
+ source = git+https://github.com/ThePBone/gst-plugin-jamesdsp.git
+ sha256sums = SKIP
+
+pkgname = gst-plugin-jamesdsp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a43e460164d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=gst-plugin-jamesdsp-git
+pkgver=r14.378f0fa
+pkgrel=1
+pkgdesc="JamesDSP wrapper plugin for GStreamer"
+arch=('x86_64')
+url="https://github.com/ThePBone/gst-plugin-jamesdsp"
+license=('GPL2')
+depends=('gst-plugins-base-libs')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" 'gst-plugin-viper4linux' 'gst-plugin-viperfx')
+install="${pkgname%-git}.install"
+source=('git+https://github.com/ThePBone/gst-plugin-jamesdsp.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/gst-plugin-jamesdsp.install b/gst-plugin-jamesdsp.install
new file mode 100644
index 000000000000..5530ac2cb82f
--- /dev/null
+++ b/gst-plugin-jamesdsp.install
@@ -0,0 +1,8 @@
+post_install() {
+ # libtool: warning: remember to run 'libtool --finish /usr/lib/gstreamer-1.0'
+ libtool --finish /usr/lib/gstreamer-1.0
+}
+
+post_upgrade() {
+ post_install
+}