summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2018-06-17 02:05:17 +0200
committerDavide Depau2018-06-17 02:05:17 +0200
commite6167fd07822e6448bc5f1eed8c88b49892a64f2 (patch)
tree2d5ffc3b78c961b940e09923e571d6ebcc33afe2
downloadaur-e6167fd07822e6448bc5f1eed8c88b49892a64f2.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--0001-Set-license-to-a-gst-supported-one.patch25
-rw-r--r--PKGBUILD41
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d896945b58d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gst-plugin-viperfx-git
+ pkgdesc = ViPER FX core wrapper plugin for GStreamer1
+ pkgver = r2.227da1f
+ pkgrel = 1
+ url = https://github.com/vipersaudio/gst-plugin-viperfx
+ arch = x86_64
+ license = custom
+ depends = libviperfx
+ depends = gstreamer
+ provides = gst-plugin-viperfx
+ conflicts = gst-plugin-viperfx
+ source = gst-plugin-viperfx-git::git+https://github.com/vipersaudio/gst-plugin-viperfx.git
+ source = 0001-Set-license-to-a-gst-supported-one.patch
+ sha256sums = SKIP
+ sha256sums = 3f56f4b2bea7af80309b0ea668877d6fb028677aab966eb946ba4463dd118eea
+
+pkgname = gst-plugin-viperfx-git
+
diff --git a/0001-Set-license-to-a-gst-supported-one.patch b/0001-Set-license-to-a-gst-supported-one.patch
new file mode 100644
index 000000000000..4e83af1cc7a4
--- /dev/null
+++ b/0001-Set-license-to-a-gst-supported-one.patch
@@ -0,0 +1,25 @@
+From 4e0d0d0d15d50fb5f9ab28dbf49069cf0f895b27 Mon Sep 17 00:00:00 2001
+From: Davide Depau <davide@depau.eu>
+Date: Sun, 17 Jun 2018 01:55:03 +0200
+Subject: [PATCH] Set license to a gst-supported one
+
+---
+ src/gstviperfx.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gstviperfx.c b/src/gstviperfx.c
+index 0a50765..3120e77 100644
+--- a/src/gstviperfx.c
++++ b/src/gstviperfx.c
+@@ -1558,7 +1558,7 @@ GST_PLUGIN_DEFINE (
+ "viperfx element",
+ viperfx_init,
+ VERSION,
+- "NonGPL",
++ "Proprietary",
+ "GStreamer",
+ "http://gstreamer.net/"
+ )
+--
+2.17.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e249e554cdb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Davide Depau <davide@depau.eu>
+
+pkgname=gst-plugin-viperfx-git
+pkgver=r2.227da1f
+pkgrel=1
+pkgdesc="ViPER FX core wrapper plugin for GStreamer1"
+url="https://github.com/vipersaudio/gst-plugin-viperfx"
+arch=("x86_64")
+license=("custom")
+provides=("gst-plugin-viperfx")
+conflicts=("gst-plugin-viperfx")
+depends=("libviperfx" "gstreamer")
+source=(
+ "$pkgname::git+https://github.com/vipersaudio/gst-plugin-viperfx.git"
+ "0001-Set-license-to-a-gst-supported-one.patch"
+)
+sha256sums=('SKIP'
+ '3f56f4b2bea7af80309b0ea668877d6fb028677aab966eb946ba4463dd118eea')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p1 < $srcdir/0001-Set-license-to-a-gst-supported-one.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
+ make
+}
+
+package() {
+ install -Dm755 "$srcdir/$pkgname/src/.libs/libgstviperfx.so" "$pkgdir/usr/lib/gstreamer-1.0/libgstviperfx.so"
+}