summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorent Thiéry2015-12-11 10:37:26 +0100
committerFlorent Thiéry2015-12-11 10:37:26 +0100
commit6f3519a8391c583e5a31b46d4faca113620483cd (patch)
treeb113e5ee2c036a08104568b4197a371e30d28af7
downloadaur-6f3519a8391c583e5a31b46d4faca113620483cd.tar.gz
Initial import
-rw-r--r--.SRCINFO60
-rw-r--r--PKGBUILD51
2 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..311759c74756
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,60 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 09:37:14 UTC 2015
+pkgbase = gst-plugins-bad-rpi-nox
+ pkgdesc = GStreamer Multimedia Framework Bad Plugins with compilation options optimized for RaspberryPi so that glimagesink works without Xorg
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = http://gstreamer.freedesktop.org/
+ arch = armv6h
+ license = LGPL
+ makedepends = schroedinger
+ makedepends = libexif
+ makedepends = libdvdread
+ makedepends = libvdpau
+ makedepends = libmpeg2
+ makedepends = python
+ makedepends = wildmidi
+ makedepends = librsvg
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = libtiger
+ makedepends = ladspa
+ makedepends = libusb
+ makedepends = raspberrypi-firmware-tools
+ depends = mjpegtools
+ depends = gst-plugins-base-libs
+ depends = curl
+ depends = chromaprint
+ depends = libmms
+ depends = faad2
+ depends = mpg123
+ depends = faac
+ depends = celt
+ depends = libdca
+ depends = soundtouch
+ depends = spandsp
+ depends = libdvdnav
+ depends = libmodplug
+ depends = libgme
+ depends = opus
+ depends = wayland
+ depends = neon
+ depends = libofa
+ depends = fluidsynth
+ depends = openjpeg
+ depends = libwebp
+ depends = libsrtp
+ depends = gnutls
+ depends = wildmidi
+ depends = glu
+ depends = sbc
+ depends = rtmpdump
+ depends = libgudev
+ depends = raspberrypi-firmware-tools
+ conflicts = gst-plugins-bad
+ options = !emptydirs
+ source = http://gstreamer.freedesktop.org//src/gst-plugins-bad/gst-plugins-bad-1.6.1.tar.xz
+ sha256sums = e176a9af125f6874b3d6724aa7566a198fa225d3ece0a7ac2f2b51c57e525466
+
+pkgname = gst-plugins-bad-rpi-nox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd369a35d4c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+# Maintainer: Florent Thiéry <fthiery@gmail.com>
+_pkgname=gst-plugins-bad
+pkgname=$_pkgname-rpi-nox
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="GStreamer Multimedia Framework Bad Plugins with compilation options optimized for RaspberryPi so that glimagesink works without Xorg"
+arch=('armv6h')
+license=('LGPL')
+url="http://gstreamer.freedesktop.org/"
+depends=('mjpegtools' 'gst-plugins-base-libs' 'curl' 'chromaprint' 'libmms' 'faad2' 'mpg123' 'faac' 'celt' 'libdca' 'soundtouch' 'spandsp' 'libdvdnav' 'libmodplug' 'libgme' 'opus' 'wayland' 'neon' 'libofa' 'fluidsynth' 'openjpeg' 'libwebp' 'libsrtp' 'gnutls' 'wildmidi' 'glu' 'sbc' 'rtmpdump' 'libgudev' 'raspberrypi-firmware-tools')
+makedepends=('schroedinger' 'libexif' 'libdvdread' 'libvdpau' 'libmpeg2' 'python' 'wildmidi' 'librsvg' 'gobject-introspection' 'gtk-doc' 'libtiger' 'ladspa' 'libusb' 'raspberrypi-firmware-tools')
+conflicts=('gst-plugins-bad')
+options=(!emptydirs)
+source=(${url}/src/$_pkgname/$_pkgname-$pkgver.tar.xz)
+sha256sums=('e176a9af125f6874b3d6724aa7566a198fa225d3ece0a7ac2f2b51c57e525466')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ autoreconf -vi
+}
+
+build() {
+ cd $_pkgname-$pkgver
+
+ ./configure CFLAGS="-I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads\
+ -I/opt/vc/include/interface/vmcs_host/linux/" LDFLAGS="-L/opt/vc/lib" \
+ --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-opengl --disable-glx --enable-gles2 --enable-egl --enable-dispmanx \
+ --with-gles2-module-name=/opt/vc/lib/libGLESv2.so --with-egl-module-name=/opt/vc/lib/libEGL.so \
+ --disable-static --enable-experimental --enable-gtk-doc \
+ --with-package-name="GStreamer Bad Plugins (Arch Linux)" \
+ --with-package-origin="http://www.archlinux.org/" \
+ --with-gtk=3.0
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+check() {
+ cd $_pkgname-$pkgver
+ # don't have a camera for the camerabin test
+ make -k check || :
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="${pkgdir}" install
+}