summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-12-03 07:23:04 -0500
committerSolomon Choina2019-12-03 07:23:04 -0500
commitb64093c7154831feb068b59497153649c8902190 (patch)
tree0d0619712fb016b0cc9f3a399041fb51822709f7
parent15eeb086d37cc152564f23839e755f2446916775 (diff)
downloadaur-b64093c7154831feb068b59497153649c8902190.tar.gz
autotools has been purged and moving to meson which i forgot to git add and push
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD55
2 files changed, 45 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5491b98627c..a99e32f3cb7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gst-plugins-base-git
pkgdesc = GStreamer Multimedia Framework Base Plugins
- pkgver = 1.17.0.1.19939.2e686b0da
+ pkgver = 1.16.0.r280.g2c7445b9c
pkgrel = 1
url = http://gstreamer.freedesktop.org/
arch = i686
@@ -19,24 +19,31 @@ pkgbase = gst-plugins-base-git
makedepends = glu
makedepends = pango
makedepends = gobject-introspection
+ makedepends = meson
depends = gstreamer-git
depends = orc
depends = libxv
depends = opus
+ depends = gdk-pixbuf2
depends = alsa-lib
depends = cdparanoia
depends = libjpeg-turbo
+ depends = gtk3
+ depends = graphene
depends = libvisual
depends = libvorbis
depends = libtheora
depends = pango
- provides = gst-plugins-base=1.17.0.1.19939.2e686b0da
- provides = gst-plugins-base-libs=1.17.0.1.19939.2e686b0da
+ depends = libtremor-svn
+ depends = sdl2
+ depends = qt5-base
+ provides = gst-plugins-base=1.16.0.r280.g2c7445b9c
+ provides = gst-plugins-base-libs=1.16.0.r280.g2c7445b9c
conflicts = gst-plugins-base
conflicts = gst-plugins-base-libs
- options = !libtool
- options = !emptydirs
- source = git://anongit.freedesktop.org/gstreamer/gst-plugins-base
+ source = git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-base.git
+ source = gst-common::git+https://gitlab.freedesktop.org/gstreamer/common.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = gst-plugins-base-git
diff --git a/PKGBUILD b/PKGBUILD
index 39e69c86b7e7..fe6e5bca299b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,59 @@
# Original Package: Jan de Groot <jgc@archlinux.org>
# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname='gst-plugins-base-git'
-pkgver=1.17.0.1.19939.2e686b0da
+pkgver=1.16.0.r280.g2c7445b9c
pkgrel=1
pkgdesc="GStreamer Multimedia Framework Base Plugins"
arch=('i686' 'x86_64')
license=('LGPL')
-makedepends=('pkgconfig' 'git' 'gstreamer-git'
- 'orc' 'libxv' 'alsa-lib' 'cdparanoia'
- 'libvisual' 'libvorbis' 'libtheora' 'glu'
- 'pango' 'gobject-introspection')
-options=(!libtool !emptydirs)
+makedepends=('pkgconfig' 'git' 'gstreamer-git'
+ 'orc' 'libxv' 'alsa-lib' 'cdparanoia'
+ 'libvisual' 'libvorbis' 'libtheora' 'glu'
+ 'pango' 'gobject-introspection' 'meson')
+options=()
url="http://gstreamer.freedesktop.org/"
conflicts=('gst-plugins-base' 'gst-plugins-base-libs')
provides=('gst-plugins-base='$pkgver 'gst-plugins-base-libs='$pkgver)
pkgdesc="GStreamer Multimedia Framework Base Plugins"
-depends=('gstreamer-git' 'orc' 'libxv' 'opus'
- 'alsa-lib' 'cdparanoia' 'libjpeg-turbo'
- 'libvisual' 'libvorbis' 'libtheora' 'pango')
+depends=('gstreamer-git' 'orc' 'libxv' 'opus' 'gdk-pixbuf2'
+ 'alsa-lib' 'cdparanoia' 'libjpeg-turbo' 'gtk3' 'graphene'
+ 'libvisual' 'libvorbis' 'libtheora' 'pango' 'libtremor-svn' 'sdl2' 'qt5-base')
+
+source=('git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-base.git'
+ 'gst-common::git+https://gitlab.freedesktop.org/gstreamer/common.git')
+sha256sums=('SKIP'
+ 'SKIP')
-source=('git://anongit.freedesktop.org/gstreamer/gst-plugins-base')
-sha256sums=('SKIP')
-_gitname='gst-plugins-base'
pkgver() {
- cd $_gitname
- version=$(grep AC_INIT configure.ac | sed 's/AC_INIT(\[GStreamer Base Plug-ins\],\[//' | sed 's/\],\[http:\/\/bugzilla.gnome.org\/enter_bug.cgi?product=GStreamer\],\[gst-plugins-base\])//')
- hash=$(git log --pretty=format:'%h' -n 1)
- revision=$(git rev-list --count HEAD)
+ cd gst-plugins-base
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
- echo $version.$revision.$hash
+prepare() {
+ cd gst-plugins-base
+ git submodule init
+ git config --local submodule.common.url "$srcdir/gst-common"
+ git submodule update
}
build() {
- cd $_gitname
- ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --disable-static --enable-experimental
- make
+ arch-meson gst-plugins-base build \
+ -Ddoc=disabled \
+ -Dgobject-cast-checks=disabled \
+ -Dglib-asserts=disabled \
+ -Dglib-checks=disabled \
+ -Dpackage-name="GStreamer Base Plugins (Arch Linux)" \
+ -Dpackage-origin="https://aur.archlinux.org/"
+ ninja -C build
}
package() {
- cd $_gitname
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -C build install
}