summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-05-31 14:09:53 -0400
committerSolomon Choina2018-05-31 14:09:53 -0400
commit06c7c7c160a8bc99d7862bf196d4f02049f54b0f (patch)
tree6d205acc8c0fffec453bdac7f64f0e7dc579c640
parentde433ef709f97ae85c98d0ab5409e862a41f2146 (diff)
downloadaur-06c7c7c160a8bc99d7862bf196d4f02049f54b0f.tar.gz
moving to meson and https
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 600b149cbce8..6db6269f3bdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
-# Generated by mksrcinfo v8
-# Sun Jun 18 18:52:11 UTC 2017
pkgbase = gst-plugins-good-git
pkgdesc = GStreamer Multimedia Framework Good Plugins
- pkgver = 1.13.0.1.16696.0da5679c6
+ pkgver = 1.15.0.1.17695.0fbde2a07
pkgrel = 1
url = http://gstreamer.freedesktop.org/
arch = i686
arch = x86_64
license = LGPL
+ makedepends = git
+ makedepends = meson
makedepends = gstreamer
makedepends = speex
makedepends = flac
@@ -29,11 +29,11 @@ pkgbase = gst-plugins-good-git
depends = libxdamage
depends = v4l-utils
depends = cairo
- provides = gst-plugins-good=1.13.0.1.16696.0da5679c6
+ provides = gst-plugins-good=1.15.0.1.17695.0fbde2a07
conflicts = gst-plugins-good
options = !libtool
options = !emptydirs
- source = git://anongit.freedesktop.org/gstreamer/gst-plugins-good
+ source = git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-good.git
sha256sums = SKIP
pkgname = gst-plugins-good-git
diff --git a/PKGBUILD b/PKGBUILD
index 182259dc9503..1f0ca34f8596 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Original Package: Jan de Groot <jgc@archlinux.org>
# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname=gst-plugins-good-git
-pkgver=1.13.0.1.16696.0da5679c6
+pkgver=1.15.0.1.17695.0fbde2a07
pkgrel=1
pkgdesc="GStreamer Multimedia Framework Good Plugins"
arch=('i686' 'x86_64')
@@ -11,10 +12,10 @@ provides=('gst-plugins-good='$pkgver)
conflicts=('gst-plugins-good')
url="http://gstreamer.freedesktop.org/"
depends=('libpulse' 'jack' 'libsoup' 'gst-plugins-base-git' 'wavpack' 'aalib' 'taglib' 'libdv' 'libshout' 'libvpx' 'gdk-pixbuf2' 'libcaca' 'libavc1394' 'libiec61883' 'libxdamage' 'v4l-utils' 'cairo')
-makedepends=('gstreamer' 'speex' 'flac' 'libraw1394')
+makedepends=('git' 'meson' 'gstreamer' 'speex' 'flac' 'libraw1394')
options=(!libtool !emptydirs)
-source=('git://anongit.freedesktop.org/gstreamer/gst-plugins-good')
+source=('git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-good.git')
sha256sums=('SKIP')
_gitname='gst-plugins-good'
@@ -29,14 +30,10 @@ pkgver() {
}
build() {
- cd $_gitname
- export CFLAGS="-Wno-error"
- ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --disable-static --enable-experimental --disable-fatal-warnings
- make
+ arch-meson $_gitname build
+ ninja -C build
}
package() {
- cd $_gitname
- make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -C build install
}