summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOle André Vadla Ravnås2017-11-09 20:28:26 +0100
committerOle André Vadla Ravnås2017-11-09 20:28:26 +0100
commit14b97a03616910284592a85930722e9e30897915 (patch)
treed6769de8cb08fd251f9010c9ee9b0522231c55bd
downloadaur-14b97a03616910284592a85930722e9e30897915.tar.gz
Initial commit
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD64
2 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d579d31c7372
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = gst-plugins-good-oleavr
+ pkgdesc = GStreamer Multimedia Framework Good Plugins
+ pkgver = master
+ pkgrel = 1
+ url = https://github.com/oleavr/gst-plugins-good
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ checkdepends = gst-plugins-base
+ makedepends = python
+ makedepends = gtk-doc
+ makedepends = autoconf-archive
+ makedepends = git
+ depends = libpulse
+ depends = jack
+ depends = libsoup
+ depends = gst-plugins-base-libs
+ depends = wavpack
+ depends = aalib
+ depends = taglib
+ depends = libdv
+ depends = libshout
+ depends = libvpx
+ depends = gdk-pixbuf2
+ depends = libcaca
+ depends = libavc1394
+ depends = libiec61883
+ depends = libxdamage
+ depends = v4l-utils
+ depends = cairo
+ depends = libgudev
+ depends = speex
+ depends = flac
+ depends = libraw1394
+ provides = gst-plugins-good
+ conflicts = gst-plugins-good
+ source = git+https://github.com/oleavr/gst-plugins-good
+ source = gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gst-plugins-good-oleavr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4886ced4cbb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# $Id$
+# Maintainer: Ole André Vadla Ravnås <oleavr@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+_name=gst-plugins-good
+pkgname=gst-plugins-good-oleavr
+pkgver=1.12.0.r545.g770bb07f3
+pkgrel=1
+pkgdesc="GStreamer Multimedia Framework Good Plugins"
+url="https://github.com/oleavr/gst-plugins-good"
+arch=(i686 x86_64)
+license=(LGPL)
+depends=(libpulse jack libsoup gst-plugins-base-libs wavpack aalib taglib libdv libshout libvpx
+ gdk-pixbuf2 libcaca libavc1394 libiec61883 libxdamage v4l-utils cairo libgudev speex flac
+ libraw1394)
+makedepends=(python gtk-doc autoconf-archive git)
+checkdepends=(gst-plugins-base)
+provides=("$_name")
+conflicts=("$_name")
+source=("git+https://github.com/oleavr/gst-plugins-good"
+ "gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_name"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_name"
+
+ git submodule init
+ git config --local submodule.common.url "$srcdir/gst-common"
+ git submodule update
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "$srcdir/$_name"
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib \
+ --with-package-name="GStreamer Good Plugins (Arch Linux)" \
+ --with-package-origin="https://www.archlinux.org/" \
+ --disable-fatal-warnings \
+ --enable-experimental --enable-gtk-doc --disable-static
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+check() {
+ cd "$srcdir/$_name"
+ make check
+}
+
+package() {
+ cd "$srcdir/$_name"
+ make DESTDIR="$pkgdir" install
+}