summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Scheirer2016-02-05 20:21:09 -0500
committerMatt Scheirer2016-02-05 20:21:09 -0500
commitbfec413ee22824492d8ed6db690750cb13404f9a (patch)
tree2ee3efe13e396a3b9cb98df015a294482596fd13
downloadaur-bfec413ee22824492d8ed6db690750cb13404f9a.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..404e2a2a4201
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Feb 6 01:18:57 UTC 2016
+pkgbase = gst-plugins-openwebrtc
+ pkgdesc = OpenWebRTC specific GStreamer plugins
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/EricssonResearch/openwebrtc-gst-plugins
+ arch = i386
+ arch = x86_64
+ groups = gst-plugins
+ license = BSD
+ depends = gst-plugins-base-libs
+ depends = libusrsctp-git
+ provides = gst-plugins-openwebrtc
+ conflicts = gst-plugins-openwebrtc-git
+ source = https://github.com/EricssonResearch/openwebrtc-gst-plugins/archive/v0.3.0.tar.gz
+ sha256sums = 72829906ad3d588cf0a260712a74b25ffd773ea623f67b9d4423da32e07e4180
+
+pkgname = gst-plugins-openwebrtc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bb15ec38db5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Zanny <lordzanny@gmail.com>
+
+pkgname=gst-plugins-openwebrtc
+_remote=openwebrtc-gst-plugins
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="OpenWebRTC specific GStreamer plugins"
+arch=(i386 x86_64)
+url="https://github.com/EricssonResearch/openwebrtc-gst-plugins"
+license=('BSD')
+groups=(gst-plugins)
+depends=(gst-plugins-base-libs libusrsctp-git)
+provides=(gst-plugins-openwebrtc)
+conflicts=(gst-plugins-openwebrtc-git)
+source=("https://github.com/EricssonResearch/$_remote/archive/v$pkgver.tar.gz")
+sha256sums=('72829906ad3d588cf0a260712a74b25ffd773ea623f67b9d4423da32e07e4180')
+
+build() {
+ cd "$srcdir/$_remote-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$_remote-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$_remote-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}