summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArne Hoch2015-06-30 09:06:20 +0200
committerArne Hoch2015-06-30 09:06:20 +0200
commit689f40228ca755f26827e786593cda9e9f3a59c2 (patch)
tree516336865d991992f31945a8d8923e4811c77eb1
downloadaur-689f40228ca755f26827e786593cda9e9f3a59c2.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c03eb71cf69f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gst-rpicamsrc-git
+ pkgdesc = GStreamer element to access the RaspberryPI Camera.
+ pkgver = r65.a1f5588
+ pkgrel = 1
+ url = https://github.com/thaytan/gst-rpicamsrc
+ arch = armv6h
+ license = LGPL
+ depends = gst-plugins-base
+ depends = raspberrypi-firmware-tools
+ options = !libtool
+ source = git+https://github.com/thaytan/gst-rpicamsrc.git
+ md5sums = SKIP
+
+pkgname = gst-rpicamsrc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2037c7e13a2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Arne Hoch <arne at derhoch dot de>
+
+pkgname=gst-rpicamsrc-git
+_gitname=gst-rpicamsrc
+pkgver=r65.a1f5588
+pkgrel=1
+pkgdesc="GStreamer element to access the RaspberryPI Camera."
+arch=('armv6h')
+url="https://github.com/thaytan/gst-rpicamsrc"
+license=('LGPL')
+depends=('gst-plugins-base' 'raspberrypi-firmware-tools')
+#makedepends=('pkg-config')
+options=(!libtool)
+source=('git+https://github.com/thaytan/gst-rpicamsrc.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="${pkgdir}" install
+}