summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAliaksandr Stelmachonak a.k.a. ava1ar2017-09-26 03:22:21 -0400
committerAliaksandr Stelmachonak a.k.a. ava1ar2017-09-26 03:22:21 -0400
commit22d6fb05dabeb9f8f1eb72ab666d763d3db1059a (patch)
tree76b1126b914426b46498334a1cdb30890d271996
parent34fff79bb5ff4941b5d5532f66a5d8e5c085d542 (diff)
downloadaur-22d6fb05dabeb9f8f1eb72ab666d763d3db1059a.tar.gz
Adopted, changed source to the tarball, fix package build
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
-rw-r--r--revert-decodebin-playbin-removal.patch122
3 files changed, 14 insertions, 143 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ed5c5f6da49..d9819ff943a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Tue Sep 26 07:21:57 UTC 2017
pkgbase = gstreamer0.10-base
pkgver = 0.10.36
- pkgrel = 9
+ pkgrel = 11
url = http://gstreamer.freedesktop.org/
arch = x86_64
arch = armv7h
@@ -16,19 +18,16 @@ pkgbase = gstreamer0.10-base
makedepends = libtheora
makedepends = pango
makedepends = gobject-introspection
- makedepends = git
options = !emptydirs
- source = git+https://gitlab.com/gstreamer-sdk/gst-plugins-base.git#commit=48d5966f12d4e6b71c96db0600cf76ef0ef14b3a
+ source = https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-0.10.36.tar.xz
source = fix-crash-0-byte-ogg.patch
source = colorbalance-fix-abi.patch
- source = revert-decodebin-playbin-removal.patch
source = videoscale-fix-negotiation.patch
source = ayuv64-lanczos.patch
source = gstaudio-symbols.patch
- sha256sums = SKIP
+ sha256sums = 1fe45c3894903001d4d008b0713dab089f53726dcb5842d5b40c2595a984e64a
sha256sums = a6a01035ea9627737f9c17f72919857ed43ccc7c2cb08b645b43ed89f78d0f4f
sha256sums = 7442c5c68068428b8c7ac1d3825ce29f1bb152b75b77047b9e806c7d322b780c
- sha256sums = ba20659fafea73db016ddaecd128f12087e0957ce35cf2c3ce29f72c51551ef3
sha256sums = ae27f7be58997217f67898b37b138a485c203389e56b65e6b31c23f769ef39ca
sha256sums = 3792dfe80c69f51c0db98533e8fb16707b5dd2ee6933ea6098583af873ceb44a
sha256sums = 56e7a988df39d2ec4befa265536ad8c30d3c8d18d136cebef64e8d6baac1abae
diff --git a/PKGBUILD b/PKGBUILD
index 7fdc242da081..2de0cd9acdc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,46 +5,40 @@ pkgbase=gstreamer0.10-base
_pkgname=gst-plugins-base
pkgname=('gstreamer0.10-base' 'gstreamer0.10-base-plugins')
pkgver=0.10.36
-pkgrel=10
+pkgrel=11
arch=('x86_64' 'armv7h')
license=('LGPL')
makedepends=('pkgconfig' 'gstreamer0.10>=0.10.36-7' 'orc' 'libxv' 'alsa-lib' 'cdparanoia'
- 'libvisual' 'libvorbis' 'libtheora' 'pango' 'gobject-introspection' 'git')
+ 'libvisual' 'libvorbis' 'libtheora' 'pango' 'gobject-introspection')
options=(!emptydirs)
url='http://gstreamer.freedesktop.org/'
-source=("git+https://gitlab.com/gstreamer-sdk/$_pkgname.git#commit=48d5966f12d4e6b71c96db0600cf76ef0ef14b3a"
+source=("https://gstreamer.freedesktop.org/src/${_pkgname}/${_pkgname}-${pkgver}.tar.xz"
fix-crash-0-byte-ogg.patch
colorbalance-fix-abi.patch
- revert-decodebin-playbin-removal.patch
videoscale-fix-negotiation.patch
ayuv64-lanczos.patch
gstaudio-symbols.patch)
-sha256sums=('SKIP'
+sha256sums=('1fe45c3894903001d4d008b0713dab089f53726dcb5842d5b40c2595a984e64a'
'a6a01035ea9627737f9c17f72919857ed43ccc7c2cb08b645b43ed89f78d0f4f'
'7442c5c68068428b8c7ac1d3825ce29f1bb152b75b77047b9e806c7d322b780c'
- 'ba20659fafea73db016ddaecd128f12087e0957ce35cf2c3ce29f72c51551ef3'
'ae27f7be58997217f67898b37b138a485c203389e56b65e6b31c23f769ef39ca'
'3792dfe80c69f51c0db98533e8fb16707b5dd2ee6933ea6098583af873ceb44a'
'56e7a988df39d2ec4befa265536ad8c30d3c8d18d136cebef64e8d6baac1abae')
prepare() {
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
sed -i -e '/AC_PATH_XTRA/d' -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
patch -Np1 -i ../fix-crash-0-byte-ogg.patch
patch -Np1 -i ../colorbalance-fix-abi.patch
patch -Np1 -i ../ayuv64-lanczos.patch
patch -Np1 -i ../videoscale-fix-negotiation.patch
patch -Np1 -i ../gstaudio-symbols.patch
- patch -Np1 -R -i ../revert-decodebin-playbin-removal.patch
}
build() {
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
NOCONFIGURE=1 ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --disable-static --enable-experimental --disable-gnome_vfs --disable-gtk-doc #\
- # --with-package-name="GStreamer Base Plugins (Archlinux)" \
- # --with-package-origin="http://www.archlinux.org/"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static --enable-experimental --disable-gnome_vfs --disable-gtk-doc
make
sed -e 's/^SUBDIRS_EXT =.*/SUBDIRS_EXT =/' -i Makefile
}
@@ -53,7 +47,7 @@ package_gstreamer0.10-base() {
pkgdesc="GStreamer Multimedia Framework Base plugin libraries"
depends=('gstreamer0.10>=0.10.36' 'orc' 'libxv')
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
}
@@ -64,7 +58,7 @@ package_gstreamer0.10-base-plugins() {
conflicts=('gstreamer0.10-alsa' 'gstreamer0.10-theora' 'gstreamer0.10-libvisual' 'gstreamer0.10-pango' 'gstreamer0.10-cdparanoia' 'gstreamer0.10-vorbis' 'gstreamer0.10-ogg')
groups=('gstreamer0.10-plugins')
- cd $_pkgname
+ cd ${_pkgname}-${pkgver}
make -C gst-libs DESTDIR="${pkgdir}" install
make -C ext DESTDIR="${pkgdir}" install
make -C gst-libs DESTDIR="${pkgdir}" uninstall
diff --git a/revert-decodebin-playbin-removal.patch b/revert-decodebin-playbin-removal.patch
deleted file mode 100644
index 2e5913930b94..000000000000
--- a/revert-decodebin-playbin-removal.patch
+++ /dev/null
@@ -1,122 +0,0 @@
-From fece626254e3b250e4514d1c92ac8289421d9511 Mon Sep 17 00:00:00 2001
-From: Sebastian Dröge <sebastian.droege@collabora.co.uk>
-Date: Thu, 15 Mar 2012 11:34:22 +0000
-Subject: Disable old playbin and decodebin
-
----
-diff --git a/gst/playback/Makefile.am b/gst/playback/Makefile.am
-index a0f1abc..700f581 100644
---- a/gst/playback/Makefile.am
-+++ b/gst/playback/Makefile.am
-@@ -6,19 +6,15 @@ glib_gen_basename = gstplay
- built_sources = gstplay-marshal.c
- built_headers = gstplay-marshal.h
-
--plugin_LTLIBRARIES = libgstplaybin.la libgstdecodebin.la libgstdecodebin2.la
-+plugin_LTLIBRARIES = libgstplaybin.la libgstdecodebin2.la
-
- csp_cflags = -DCOLORSPACE=\"ffmpegcolorspace\"
-
- libgstplaybin_la_SOURCES = \
- gstplayback.c \
-- gstplaybin.c \
- gstplaybin2.c \
- gstplaysink.c \
-- gstplaybasebin.c \
- gstplay-enum.c \
-- gststreaminfo.c \
-- gststreamselector.c \
- gstsubtitleoverlay.c \
- gstplaysinkvideoconvert.c \
- gstplaysinkaudioconvert.c \
-@@ -37,17 +33,6 @@ if !GST_PLUGIN_BUILD_STATIC
- libgstplaybin_la_LIBTOOLFLAGS = --tag=disable-static
- endif
-
--libgstdecodebin_la_SOURCES = gstdecodebin.c
--nodist_libgstdecodebin_la_SOURCES = $(built_sources)
--libgstdecodebin_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(csp_cflags)
--libgstdecodebin_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
--libgstdecodebin_la_LIBADD = \
-- $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la \
-- $(GST_LIBS)
--if !GST_PLUGIN_BUILD_STATIC
--libgstdecodebin_la_LIBTOOLFLAGS = --tag=disable-static
--endif
--
- libgstdecodebin2_la_SOURCES = gstdecodebin2.c gsturidecodebin.c gstplay-enum.c
- nodist_libgstdecodebin2_la_SOURCES = $(built_sources)
- libgstdecodebin2_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(csp_cflags)
-@@ -61,11 +46,8 @@ endif
-
- noinst_HEADERS = \
- gstplayback.h \
-- gstplaybasebin.h \
- gstplaysink.h \
-- gststreaminfo.h \
- gstplay-enum.h \
-- gststreamselector.h \
- gstrawcaps.h \
- gstsubtitleoverlay.h \
- gstplaysinkvideoconvert.h \
-@@ -83,18 +65,6 @@ include $(top_srcdir)/common/gst-glib-gen.mak
-
- Android.mk: Makefile.am $(BUILT_SOURCES)
- androgenizer \
-- -:PROJECT libgstdecodebin -:SHARED libgstdecodebin \
-- -:TAGS eng debug \
-- -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
-- -:SOURCES $(libgstdecodebin_la_SOURCES) \
-- $(nodist_libgstdecodebin_la_SOURCES) \
-- -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgstdecodebin_la_CFLAGS) $(csp_cflags) \
-- -:LDFLAGS $(libgstdecodebin_la_LDFLAGS) \
-- $(libgstdecodebin_la_LIBADD) \
-- -ldl \
-- -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
-- LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
-- \
- -:PROJECT libgstdecodebin2 -:SHARED libgstdecodebin2 \
- -:TAGS eng debug \
- -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
-diff --git a/gst/playback/gstplayback.c b/gst/playback/gstplayback.c
-index 5b74786..f99df6e 100644
---- a/gst/playback/gstplayback.c
-+++ b/gst/playback/gstplayback.c
-@@ -29,8 +29,6 @@
-
- #include "gstplayback.h"
- #include "gstplaysink.h"
--#include "gststreamselector.h"
--#include "gststreaminfo.h"
- #include "gstsubtitleoverlay.h"
-
- static gboolean
-@@ -47,13 +45,7 @@ plugin_init (GstPlugin * plugin)
- bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
- #endif /* ENABLE_NLS */
-
-- /* ref class from a thread-safe context to work around missing bit of
-- * thread-safety in GObject */
-- g_type_class_ref (GST_TYPE_STREAM_INFO);
-- g_type_class_ref (GST_TYPE_STREAM_SELECTOR);
--
-- res = gst_play_bin_plugin_init (plugin);
-- res &= gst_play_bin2_plugin_init (plugin);
-+ res = gst_play_bin2_plugin_init (plugin);
- res &= gst_play_sink_plugin_init (plugin);
- res &= gst_subtitle_overlay_plugin_init (plugin);
-
-diff --git a/gst/playback/gstplayback.h b/gst/playback/gstplayback.h
-index 4be121c..5981cdd 100644
---- a/gst/playback/gstplayback.h
-+++ b/gst/playback/gstplayback.h
-@@ -24,7 +24,6 @@
- #include <gst/gst.h>
-
- gboolean gst_decode_bin_plugin_init (GstPlugin * plugin);
--gboolean gst_play_bin_plugin_init (GstPlugin * plugin);
- gboolean gst_play_bin2_plugin_init (GstPlugin * plugin);
-
-
---
-cgit v0.9.0.2-2-gbebe