summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Bryan2017-09-04 07:34:09 -0500
committerJesse Bryan2017-09-04 07:34:09 -0500
commit0d198c1989e19388f42eb8856ad8b7a5fb91a0c0 (patch)
treeba1c11ed1408f83c1202f3dda0bc6e0a5d8fa736
downloadaur-0d198c1989e19388f42eb8856ad8b7a5fb91a0c0.tar.gz
general: initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb3b0141584c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gsu
+ pkgdesc = A general screenshot and upload utility for images, video, and gifs.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/winneon/gsu
+ arch = any
+ license = MIT
+ depends = maim
+ depends = ffmpeg
+ depends = curl
+ depends = jq
+ optdepends = xclip: Copy URLs to clipboard after upload
+ source = https://codeload.github.com/winneon/gsu/tar.gz/1.0.0
+ sha256sums = f31f7a6071c8135b93d47fe7d535779f857238b579467ec8105defddb654b13e
+
+pkgname = gsu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fc891ce956d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Jesse Bryan <jesse@winneon.moe>
+pkgname=gsu
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A general screenshot and upload utility for images, video, and gifs."
+arch=("any")
+url="https://github.com/winneon/${pkgname}"
+license=("MIT")
+depends=("maim" "ffmpeg" "curl" "jq")
+optdepends=(
+ "xclip: Copy URLs to clipboard after upload"
+)
+source=("https://codeload.github.com/winneon/${pkgname}/tar.gz/${pkgver}")
+sha256sums=("f31f7a6071c8135b93d47fe7d535779f857238b579467ec8105defddb654b13e")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make DESTDIR="${pkgdir}" install
+}