summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Bryan2017-09-13 15:58:16 -0500
committerJesse Bryan2017-09-13 15:58:16 -0500
commit69e3c438a4503544cd3974151109fa2c89c89c28 (patch)
tree1b1c792188cd4a2f8109475122b35842570deb59
parenteaf6514c90a721e1d042230828b97e4101298bc0 (diff)
downloadaur-69e3c438a4503544cd3974151109fa2c89c89c28.tar.gz
release: 1.3.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2d5620d826b..40718296cf3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gsu
pkgdesc = A general screenshot and upload utility for images, video, and gifs.
- pkgver = 1.1.2
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/winneon/gsu
arch = any
@@ -10,10 +10,13 @@ pkgbase = gsu
depends = curl
depends = jq
depends = bash
- optdepends = xclip: Copy URLs to clipboard after upload
+ optdepends = xclip: Copy URLs to clipboard after upload.
+ optdepends = dmenu: Display a menu to select the output type from.
+ optdepends = rofi: Display a menu to select the output type from.
+ optdepends = libnotify: Display a notification when the utlity is finished.
conflicts = gsu-git
- source = https://codeload.github.com/winneon/gsu/tar.gz/1.1.2
- sha256sums = dbd0e04b30c309f2744e988411dbf5ecb24463a1ca7b43477a2824299a8c2e92
+ source = https://codeload.github.com/winneon/gsu/tar.gz/1.3.0
+ sha256sums = 862cfc7510871be28fd69fffe8c52ee8be757288b1021c216417a2169a0bf9b5
pkgname = gsu
diff --git a/PKGBUILD b/PKGBUILD
index e91efe69f6e2..7cf4113b3ab7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jesse Bryan <jesse@winneon.moe>
pkgname=gsu
-pkgver=1.1.2
+pkgver=1.3.0
pkgrel=1
pkgdesc="A general screenshot and upload utility for images, video, and gifs."
arch=("any")
@@ -9,10 +9,13 @@ license=("MIT")
conflicts=("${pkgname}-git")
depends=("maim" "ffmpeg" "curl" "jq" "bash")
optdepends=(
- "xclip: Copy URLs to clipboard after upload"
+ "xclip: Copy URLs to clipboard after upload."
+ "dmenu: Display a menu to select the output type from."
+ "rofi: Display a menu to select the output type from."
+ "libnotify: Display a notification when the utlity is finished."
)
source=("https://codeload.github.com/winneon/${pkgname}/tar.gz/${pkgver}")
-sha256sums=("dbd0e04b30c309f2744e988411dbf5ecb24463a1ca7b43477a2824299a8c2e92")
+sha256sums=("862cfc7510871be28fd69fffe8c52ee8be757288b1021c216417a2169a0bf9b5")
package() {
cd "${srcdir}/${pkgname}-${pkgver}"