summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlban Fichet2020-05-05 02:20:46 +0200
committerAlban Fichet2020-05-05 02:20:46 +0200
commitaba0071afd1cabd13b83a1ee519476482ec6c8bb (patch)
tree9db4baafa28d0880b81e27783da1e655d3f5f30e
parentff2be4970645e43bdc11b17316cf87aecdc3c63b (diff)
downloadaur-aba0071afd1cabd13b83a1ee519476482ec6c8bb.tar.gz
Dependencies
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b786d94d81e7..b213b138501e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc="Extension for gThumb to support OpenEXR"
arch=('any')
url="https://github.com/yama-chan/gthumb-openexr-extension"
license=('GPL')
-depends=('gthumb>=3.4' 'glib2' 'gtk3' 'gconf' 'openexr')
+depends=('git' 'meson' 'gthumb>=3.4' 'glib2' 'gtk3' 'gconf' 'openexr')
makedepends=('git' 'meson')
checkdepends=()
provides=($pkgname=$pkgver)
@@ -19,12 +19,11 @@ prepare() {
build() {
cd "$pkgname"
- meson build
- cd build
- ninja
+ meson --prefix /usr --buildtype=plain build
+ ninja -v -C build
}
package() {
cd "$pkgname"
- meson --prefix=/usr install
+ ninja -C build install
}