summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2020-03-05 20:03:31 +0100
committerLuca Weiss2020-03-05 20:03:31 +0100
commit7d1392b9c71c4373a706e412ac3085c54437a806 (patch)
tree19b25393afe24d46eda29bb7367d675e3b26917c
parent7f2f2579e35b3a195eaf0f63d7c18c86d37906fb (diff)
downloadaur-7d1392b9c71c4373a706e412ac3085c54437a806.tar.gz
upgpkg: gti 1.7.0-1
upstream release Thanks Severin!
-rw-r--r--.SRCINFO13
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD27
3 files changed, 19 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e58b5ec14b5..43773de4ed34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,12 @@
-# Generated by mksrcinfo v8
-# Tue Jun 20 13:49:16 UTC 2017
pkgbase = gti
pkgdesc = A silly git launcher
- pkgver = 1.6.1
+ pkgver = 1.7.0
pkgrel = 1
- url = http://r-wos.org/hacks/gti
- arch = i686
+ url = https://r-wos.org/hacks/gti
arch = x86_64
license = custom
- source = https://github.com/rwos/gti/archive/v1.6.1.tar.gz
- source = LICENSE
- sha512sums = a97693f43ea2b1c8b6312991ea2fd7c0eb4b9288da1992d187582f98429204c1bc81ce98a3029b30a7eecea78eb1ba6d2c3aa8497d1f104919cf7980d382c880
- sha512sums = 1ffb66b89716dfcc5d093bc63a8744e8377d4acd97d8df90c486810535c108b18f6ca1a3dd4eb3cd9027e6330392871c702ca49a72afce5a7676380788c7440f
+ source = https://github.com/rwos/gti/archive/v1.7.0.tar.gz
+ sha512sums = 7a176a36dfa73f2da1ba624bc7a721445112d7c87cf3442ba38e051c32d4d983f462f61feb797db25c575af4fde0daa402e2ebc78df81336b09c2904cdb0ca8a
pkgname = gti
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 6b29adc47370..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,8 +0,0 @@
-Copyright 2012 by Richard Wossal richard@r-wos.org
-
-Permission to use, copy, modify, distribute, and sell this software and its
-documentation for any purpose is hereby granted without fee, provided that the
-above copyright notice appear in all copies and that both that copyright notice
-and this permission notice appear in supporting documentation. No
-representations are made about the suitability of this software for any
-purpose. It is provided "as is" without express or implied warranty.
diff --git a/PKGBUILD b/PKGBUILD
index 59e4575e2b26..0f764e0976bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
# Maintainer: Antoine Lubineau <antoine@lubignon.info>
# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Contributor: Severin Glöckner <severin.gloeckner@imn.htwk-leipzig.de>
pkgname=gti
-pkgver=1.6.1
+pkgver=1.7.0
pkgrel=1
pkgdesc="A silly git launcher"
-arch=('i686' 'x86_64')
-url="http://r-wos.org/hacks/gti"
+arch=('x86_64')
+url="https://r-wos.org/hacks/gti"
license=('custom')
-source=("https://github.com/rwos/gti/archive/v$pkgver.tar.gz"
- 'LICENSE')
-sha512sums=('a97693f43ea2b1c8b6312991ea2fd7c0eb4b9288da1992d187582f98429204c1bc81ce98a3029b30a7eecea78eb1ba6d2c3aa8497d1f104919cf7980d382c880'
- '1ffb66b89716dfcc5d093bc63a8744e8377d4acd97d8df90c486810535c108b18f6ca1a3dd4eb3cd9027e6330392871c702ca49a72afce5a7676380788c7440f')
+source=("https://github.com/rwos/gti/archive/v$pkgver.tar.gz")
+sha512sums=('7a176a36dfa73f2da1ba624bc7a721445112d7c87cf3442ba38e051c32d4d983f462f61feb797db25c575af4fde0daa402e2ebc78df81336b09c2904cdb0ca8a')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed '/Copyright/,$! d' README.md > "$srcdir"/LICENSE
+}
build() {
- cd "$srcdir/gti-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
make
}
package() {
- install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm755 "gti-$pkgver/gti" "$pkgdir/usr/bin/gti"
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-
-# vim:set ts=2 sw=2 et: