summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Lubineau2012-10-08 17:11:23 +0200
committerAntoine Lubineau2012-10-08 17:11:23 +0200
commitc876798e460b0012570b254066fddf91024896de (patch)
tree6ab2918989a2f90de3b4f6aad50296eeb46b8171
downloadaur-c876798e460b0012570b254066fddf91024896de.tar.gz
gti: new package
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore0
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD28
4 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f3e03da859d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gti
+ pkgdesc = A silly git launcher
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = http://r-wos.org/hacks/gti
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = https://github.com/rwos/gti/tarball/v1.0.4
+ source = LICENSE
+ sha256sums = 72fdc62d1977052567944d709e31ac41bfdf7a179a3ac6a71a8e1c67ff2102ed
+ sha256sums = 131817f9197405ccbfed83ad13d85f8cebccfe53be11151625bdec3c9c014d0b
+
+pkgname = gti
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6b29adc47370
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,8 @@
+Copyright 2012 by Richard Wossal richard@r-wos.org
+
+Permission to use, copy, modify, distribute, and sell this software and its
+documentation for any purpose is hereby granted without fee, provided that the
+above copyright notice appear in all copies and that both that copyright notice
+and this permission notice appear in supporting documentation. No
+representations are made about the suitability of this software for any
+purpose. It is provided "as is" without express or implied warranty.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb7b78ae90c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Antoine Lubineau <antoine@lubignon.info>
+
+pkgname=gti
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="A silly git launcher"
+arch=('i686' 'x86_64')
+url="http://r-wos.org/hacks/gti"
+license=('custom')
+source=("https://github.com/rwos/gti/tarball/v$pkgver"
+ 'LICENSE')
+sha256sums=('72fdc62d1977052567944d709e31ac41bfdf7a179a3ac6a71a8e1c67ff2102ed'
+ '131817f9197405ccbfed83ad13d85f8cebccfe53be11151625bdec3c9c014d0b')
+
+build() {
+ cd "$srcdir/rwos-gti-e16ca0b"
+ make
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ cd rwos-gti-e16ca0b
+ install -Dm755 gti "$pkgdir/usr/bin/gti"
+}
+
+# vim:set ts=2 sw=2 et: