summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2013-01-16 17:15:59 +0000
committerThomas Dziedzic2013-01-16 17:15:59 +0000
commitce91efd6094b7bbaab973184af07eb4da5c23556 (patch)
tree502b313f1e87cc4420c7da139e9884dafbace9ac
parentf0d0552bb18e0fa8c3ec64b28a663cba8443e48b (diff)
downloadaur-ce91efd6094b7bbaab973184af07eb4da5c23556.tar.gz
updated on Wed Jan 16 17:15:58 UTC 2013
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff4b479067bd..41362a719877 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = gtimelog
- pkgdesc = Small Gtk+ app for keeping track of my time and producing daily/weekly activity reports
- pkgver = 0.5.0
+ pkgdesc = Small GTK+ app for keeping track of your time
+ pkgver = 0.8.0
pkgrel = 1
url = http://mg.pov.lt/gtimelog/
- arch = i686
- arch = x86_64
+ arch = any
license = GPL
- makedepends = setuptools
depends = python2
- depends = pygtk
- optdepends = dbus-python: made GTimeLog a single instance application
- source = http://pypi.python.org/packages/source/g/gtimelog/gtimelog-0.5.0.tar.gz
- md5sums = b87ee06eaefc6762d17e6380b163c755
+ depends = python2-gobject
+ depends = python2-distribute
+ source = http://pypi.python.org/packages/source/g/gtimelog/gtimelog-0.8.0.tar.gz
+ md5sums = 8a66f515d1e378f98d56038633052e55
pkgname = gtimelog
diff --git a/PKGBUILD b/PKGBUILD
index 5623052c22f5..9150eee20323 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
-# Maintainer: Bartek Piotrowski <barthalion@gmail.com>
+# Maintainer: Bartłomiej Piotrowski <barthalion@gmail.com>
pkgname=gtimelog
-pkgver=0.5.0
+pkgver=0.8.0
pkgrel=1
-pkgdesc="Small Gtk+ app for keeping track of my time and producing daily/weekly activity reports"
-arch=(i686 x86_64)
-url="http://mg.pov.lt/gtimelog/"
-license=(GPL)
-depends=('python2' 'pygtk')
-makedepends=('setuptools')
-optdepends=('dbus-python: made GTimeLog a single instance application')
-source=(http://pypi.python.org/packages/source/g/gtimelog/gtimelog-${pkgver}.tar.gz)
-md5sums=('b87ee06eaefc6762d17e6380b163c755')
+pkgdesc='Small GTK+ app for keeping track of your time'
+arch=('any')
+url='http://mg.pov.lt/gtimelog/'
+license=('GPL')
+depends=('python2' 'python2-gobject' 'python2-distribute')
+source=(http://pypi.python.org/packages/source/g/$pkgname/$pkgname-${pkgver}.tar.gz)
+md5sums=('8a66f515d1e378f98d56038633052e55')
package() {
- cd ${pkgname}-${pkgver}
- python2 setup.py install --root=${pkgdir}
+ cd "$srcdir"/$pkgname-$pkgver
+ python2 setup.py install --root="$pkgdir"
+
+ sed -i 's/env python/env python2/g' \
+ "$pkgdir"/usr/lib/python2.7/site-packages/gtimelog/main.py \
+ "$pkgdir"/usr/lib/python2.7/site-packages/gtimelog/test_gtimelog.py
}