summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-11-16 13:13:45 -0500
committeracxz2019-11-16 13:13:45 -0500
commitf6a9c3d2bee3b564e4fa92e1ae79285625c12e9a (patch)
tree43fb1b526010e0406049cff599c0ad48ce53d4ff
parent0434603072075a6b0fb0627ed31a6434f3eccd3c (diff)
downloadaur-f6a9c3d2bee3b564e4fa92e1ae79285625c12e9a.tar.gz
fix build issue if gnome-shell not installed
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD43
2 files changed, 34 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 945d6028c611..f93a84982e4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = gtk-arc-flatabulous-theme
pkgdesc = Arc theme with Flatabulous window controls.
pkgver = 20180201
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/andreisergiu98/arc-flatabulous-theme
arch = any
license = GPL3
- makedepends = git
- makedepends = gtk3
+ makedepends = autoconf
+ makedepends = automake
makedepends = sassc
+ makedepends = optipng
+ makedepends = inkscape
optdepends = gtk-engine-murrine: for gtk2 themes
- optdepends = gnome-themes-standard: for gtk2 themes
- optdepends = arc-icon-theme: recommended icon theme
+ optdepends = gnome-themes-extra: for gtk2 themes
optdepends = gtk3: for gtk3 themes
+ optdepends = gnome-shell: for detecting GNOME Shell version
conflicts = gtk-arc-flatabulous-theme
source = https://github.com/andreisergiu98/arc-flatabulous-theme/archive/20180201.tar.gz
sha256sums = 37c4a748273ed32cc5ec16fa083dfc4f708374b1a9811b03baf311265f6b5f4d
diff --git a/PKGBUILD b/PKGBUILD
index 4c05d1bcc2ba..56199bd0cc0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,47 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
# Maintainer: Joaquin Garmendia <joaquingc123 at gmail dot com>
# Contributor: Orestis Floros <orestisf1993@gmail.com>
-
-# All my PKGBUILDs can be found in https://www.github.com/joaquingx/PKGBUILDs
-
pkgname=gtk-arc-flatabulous-theme
+_pkgname=arc-flatabulous-theme
pkgver=20180201
-pkgrel=1
+pkgrel=2
pkgdesc="Arc theme with Flatabulous window controls."
arch=('any')
-url="https://github.com/andreisergiu98/${pkgname#gtk\-}"
+url="https://github.com/andreisergiu98/${_pkgname}"
license=('GPL3')
-makedepends=('git' 'gtk3' 'sassc')
+makedepends=('autoconf' 'automake' 'sassc' 'optipng' 'inkscape')
optdepends=('gtk-engine-murrine: for gtk2 themes'
- 'gnome-themes-standard: for gtk2 themes'
- 'arc-icon-theme: recommended icon theme'
+ 'gnome-themes-extra: for gtk2 themes'
'gtk3: for gtk3 themes'
+ 'gnome-shell: for detecting GNOME Shell version'
)
-source=("https://github.com/andreisergiu98/${pkgname#gtk\-}/archive/${pkgver}.tar.gz")
+source=("https://github.com/andreisergiu98/${_pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('37c4a748273ed32cc5ec16fa083dfc4f708374b1a9811b03baf311265f6b5f4d')
conflicts=('gtk-arc-flatabulous-theme')
-prepare() {
- cd "${srcdir}/${pkgname#gtk\-}-${pkgver}"
- autoreconf -fi
+_autogen_options=()
+
+check_optdepends() {
+ # Check if gnome-shell is installed
+ if (pacman -Qq gnome-shell > /dev/null) ; then
+ msg "Enabling GNOME Shell support"
+ else
+ msg "Disabling GNOME Shell support"
+ _autogen_options=(${_autogen_options[@]} --disable-gnome-shell)
+ fi
}
build() {
- cd "${srcdir}/${pkgname#gtk\-}-${pkgver}"
- ./configure --prefix=/usr
+
+ # Check optional dependencies
+ check_optdepends
+
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh ${_autogen_options[@]} --prefix=/usr
+ make
}
package() {
- cd "${srcdir}/${pkgname#gtk\-}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
}