summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2018-11-22 20:09:05 +0100
committerCarsten Teibes2018-11-22 20:09:05 +0100
commita074969d034bf4dc1181772246bcf03f695dd0f6 (patch)
tree17e4150c2b946c6222fc622be6d3f0122f46d212
parent7052f03f1c822ce925644c1bcd6ef31717dcc5df (diff)
downloadaur-a074969d034bf4dc1181772246bcf03f695dd0f6.tar.gz
[fix] new repository URL
[fix] add patch to fix a specific crash (see FS#48294)
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--fix-crasher.patch12
-rw-r--r--newer-automakes.patch21
4 files changed, 26 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a1c303f6d67..818a98ee08a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = gtk-engine-murrine-git
pkgdesc = The marvelous gtk2 cairo engine (development version)
- pkgver = 0.98.2.r406.2032a9b
+ pkgver = 0.98.2.r408.f96e446
pkgrel = 1
url = http://cimitan.com/murrine/
arch = i686
arch = x86_64
- license = LGPL
+ license = LGPL3
makedepends = git
makedepends = intltool
depends = gtk2
provides = gtk-engine-murrine
conflicts = gtk-engine-murrine
- source = gtk-engine-murrine::git+https://git.gnome.org/browse/murrine
- source = newer-automakes.patch
+ source = gtk-engine-murrine::git+https://github.com/GNOME/murrine.git
+ source = fix-crasher.patch
sha256sums = SKIP
- sha256sums = f36037693603ca450a8bc7e2c0ba7269af18640123b87fc6dd2eb11b3e423be3
+ sha256sums = e33f76ea23e38eecd2921300c7c01ff06ca33f63b9c7810d83d95e47681fe7da
pkgname = gtk-engine-murrine-git
diff --git a/PKGBUILD b/PKGBUILD
index 870d27f410a0..023436b8aa8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,20 @@
# Contributor: zhuqin <zhuqin83@gmail.com>
pkgname=gtk-engine-murrine-git
-pkgver=0.98.2.r406.2032a9b
+pkgver=0.98.2.r408.f96e446
pkgrel=1
pkgdesc="The marvelous gtk2 cairo engine (development version)"
arch=('i686' 'x86_64')
url="http://cimitan.com/murrine/"
-license=('LGPL')
+license=('LGPL3')
depends=('gtk2')
makedepends=('git' 'intltool')
conflicts=("${pkgname%-*}")
provides=("${pkgname%-*}")
-source=("${pkgname%-*}"::"git+https://git.gnome.org/browse/murrine"
- "newer-automakes.patch")
+source=("${pkgname%-*}"::"git+https://github.com/GNOME/murrine.git"
+ "fix-crasher.patch")
sha256sums=('SKIP'
- 'f36037693603ca450a8bc7e2c0ba7269af18640123b87fc6dd2eb11b3e423be3')
+ 'e33f76ea23e38eecd2921300c7c01ff06ca33f63b9c7810d83d95e47681fe7da')
pkgver() {
cd "${pkgname%-*}"
@@ -28,15 +28,15 @@ pkgver() {
}
prepare() {
- cd "${pkgname%-*}"
-
- patch -Nup1 < ../newer-automakes.patch
+ patch -d "${pkgname%-*}" -Nup1 < fix-crasher.patch
}
build() {
cd "${pkgname%-*}"
- ./autogen.sh --prefix=/usr --enable-animation --enable-animationrtl
+ intltoolize -c
+ autoreconf -i
+ ./configure --prefix=/usr --enable-animation --enable-animationrtl
make
}
diff --git a/fix-crasher.patch b/fix-crasher.patch
new file mode 100644
index 000000000000..6200e7716909
--- /dev/null
+++ b/fix-crasher.patch
@@ -0,0 +1,12 @@
+Index: gtk2-engines-murrine-0.98.2/src/murrine_style.c
+===================================================================
+--- gtk2-engines-murrine-0.98.2.orig/src/murrine_style.c
++++ gtk2-engines-murrine-0.98.2/src/murrine_style.c
+@@ -2171,6 +2171,7 @@ murrine_style_draw_layout (GtkStyle
+ cairo_t *cr;
+ cr = murrine_begin_paint (window, area);
+ cairo_translate (cr, x+xos, y+yos);
++ pango_cairo_update_layout (cr, layout);
+ pango_cairo_layout_path (cr, layout);
+ murrine_set_color_rgba (cr, &temp, 0.5);
+ cairo_stroke (cr);
diff --git a/newer-automakes.patch b/newer-automakes.patch
deleted file mode 100644
index ffc634ad74fa..000000000000
--- a/newer-automakes.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur murrine.old/autogen.sh murrine/autogen.sh
---- murrine.old/autogen.sh 2014-10-10 19:42:40.369018392 +0200
-+++ murrine/autogen.sh 2014-10-10 19:43:37.899773129 +0200
-@@ -16,7 +16,16 @@
- DIE=1
- }
-
--if automake-1.11 --version < /dev/null > /dev/null 2>&1 ; then
-+if automake-1.14 --version < /dev/null > /dev/null 2>&1 ; then
-+ AUTOMAKE=automake-1.14
-+ ACLOCAL=aclocal-1.14
-+elif automake-1.13 --version < /dev/null > /dev/null 2>&1 ; then
-+ AUTOMAKE=automake-1.13
-+ ACLOCAL=aclocal-1.13
-+elif automake-1.12 --version < /dev/null > /dev/null 2>&1 ; then
-+ AUTOMAKE=automake-1.12
-+ ACLOCAL=aclocal-1.12
-+elif automake-1.11 --version < /dev/null > /dev/null 2>&1 ; then
- AUTOMAKE=automake-1.11
- ACLOCAL=aclocal-1.11
- elif automake-1.10 --version < /dev/null > /dev/null 2>&1 ; then