summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rosenstrauch2015-10-21 01:09:20 -0400
committerDavid Rosenstrauch2015-10-21 01:09:20 -0400
commit0763f99c56be8d15297868b32e2dd2f97758883d (patch)
treeafd6a445381092f5163a8f13ac5d677fc302720d
downloadaur-0763f99c56be8d15297868b32e2dd2f97758883d.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--gtk-gnutella.install11
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3277d95a291a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gtk-gnutella
+ pkgdesc = A Gnutella server/client
+ pkgver = 1.1.5
+ pkgrel = 1
+ url = http://gtk-gnutella.sourceforge.net/
+ install = gtk-gnutella.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk2
+ depends = desktop-file-utils
+ source = http://downloads.sourceforge.net/sourceforge/gtk-gnutella/gtk-gnutella-1.1.5.tar.bz2
+ md5sums = 09ad223a1e2087e5ba36c63becd18a4a
+
+pkgname = gtk-gnutella
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9148265e8868
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer : David Rosenstrauch <darose@darose.net>
+# Prev. Maintainer : speps <speps at aur dot archlinux dot org>
+# Contributor: Dan McGee <dan@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=gtk-gnutella
+pkgver=1.1.5
+pkgrel=1
+pkgdesc="A Gnutella server/client"
+arch=('i686' 'x86_64')
+url="http://gtk-gnutella.sourceforge.net/"
+license=('GPL')
+depends=('gtk2' 'desktop-file-utils')
+install="$pkgname.install"
+source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2")
+md5sums=('09ad223a1e2087e5ba36c63becd18a4a')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./build.sh --prefix=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install INSTALL_PREFIX="$pkgdir/"
+}
diff --git a/gtk-gnutella.install b/gtk-gnutella.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/gtk-gnutella.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}