summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Playfair Cal2019-08-24 14:19:23 +1000
committerDaniel Playfair Cal2019-08-24 14:19:23 +1000
commit1a78b0aa1bbf3fa1dc0800b1be5c472420e1000c (patch)
tree5ee0ab3912909358a366fa8e35f98665fcaae5fc
downloadaur-1a78b0aa1bbf3fa1dc0800b1be5c472420e1000c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD33
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edca2b28d2fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gtk-layer-shell-git
+ pkgdesc = A library to create desktop components for Wayland using the Layer Shell protocol
+ pkgver = r128.b2e6554
+ pkgrel = 1
+ url = https://github.com/wmww/gtk-layer-shell
+ arch = x86_64
+ makedepends = meson
+ makedepends = wayland
+ makedepends = gtk3
+ makedepends = gobject-introspection
+ provides = gtk-layer-shell
+ source = git+https://github.com/wmww/gtk-layer-shell.git
+ md5sums = SKIP
+
+pkgname = gtk-layer-shell-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e7c8a9e72250
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc49830c63e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Daniel Playfair Cal (hedgepigdaniel) <daniel.playfair.cal@gmail.com>
+
+pkgname=gtk-layer-shell-git
+_pkgname=gtk-layer-shell
+pkgver=r128.b2e6554
+pkgrel=1
+provides=( gtk-layer-shell )
+pkgdesc="A library to create desktop components for Wayland using the Layer Shell protocol"
+arch=(x86_64)
+url="https://github.com/wmww/gtk-layer-shell"
+makedepends=(meson wayland gtk3 gobject-introspection)
+source=("git+https://github.com/wmww/gtk-layer-shell.git")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+}
+
+build() {
+ meson $_pkgname build --prefix=/usr
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
+
+# vim:set sw=2 et:
+md5sums=('SKIP')