summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorston2022-08-20 02:28:25 +0800
committerston2022-08-20 02:28:25 +0800
commit3377a7498616109fefd403e256f2fb37cf32b281 (patch)
tree807544ca37159c12067f54b6179f4af19c6b6b24
parent25239a4c50074027fde0afa532c101708070af2d (diff)
downloadaur-3377a7498616109fefd403e256f2fb37cf32b281.tar.gz
If you have rustup , not update it.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da3a45662439..414004f6470e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gtk-qq-git
pkgdesc = Unofficial Linux QQ client, based on GTK4.
- pkgver = 0.2.0.r137.g0be2283
- pkgrel = 2
+ pkgver = 0.2.0.r157.g8248cb3
+ pkgrel = 1
url = https://github.com/lomirus/gtk-qq
arch = any
license = AGPL3
diff --git a/PKGBUILD b/PKGBUILD
index 1938119b93cb..57fb4e5130d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer:ston<2424284164@qq.com>
pkgname=gtk-qq-git
-pkgver=0.2.0.r137.g0be2283
-pkgrel=2
+pkgver=0.2.0.r157.g8248cb3
+pkgrel=1
pkgdesc="Unofficial Linux QQ client, based on GTK4."
arch=('any')
url="https://github.com/lomirus/gtk-qq"
@@ -24,14 +24,23 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd gtk-qq
- #force to use nightly
- rustup install nightly
- rustup override set nightly
+ # check rustc-nightly
+ set -e;
+ rustup run nightly rustc --version|| EXIT_CODE=$? && true ;
+ if [ '$EXIT_CODE' == '1' ];then
+ rustup install nightly
+ fi
# setup
meson setup builddir
meson compile -C builddir
+}
+
+build() {
+ cd gtk-qq
+ #force to use nightly
+ rustup override set nightly
cargo build --release
}
@@ -51,5 +60,4 @@ package() {
install -Dm644 ${srcdir}/gtk-qq.png ${pkgdir}/usr/share/icons/hicolor/256x256/apps/gtk-qq.png
# desktop
install -Dm644 ${srcdir}/gtk-qq.desktop ${pkgdir}/usr/share/applications/gtk-qq.desktop
-
}