summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-11-29 21:06:29 +0100
committerFabioLolix2020-11-29 21:06:29 +0100
commit9c4dae0b06a1f1ae06ec807cba7a154f01104790 (patch)
tree890b1c0f40cecc3a5a11bf3089ecaf1afb464f83
parent97d24e887a5e5f86b1a68b547a86623b91bdd421 (diff)
downloadaur-gtk-sharp-2-git.tar.gz
revision
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1d36001a34b..241fdcaf7e79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = gtk-sharp-2-git
- pkgdesc = C# bindings for GTK+ 2, built from sources.
- pkgver = 2.12
+ pkgdesc = C# bindings for GTK+ 2
+ pkgver = 2.12.45.r48.ga915b2c67
pkgrel = 1
url = https://mono-project.com/GtkSharp
arch = any
license = GPL
+ makedepends = git
depends = mono
depends = gtk2
depends = libglade
provides = gtk-sharp-2
conflicts = gtk-sharp-2
- source = git://github.com/mono/gtk-sharp.git#branch=gtk-sharp-2-12-branch
- md5sums = SKIP
+ source = git+https://github.com/mono/gtk-sharp.git#branch=gtk-sharp-2-12-branch
+ sha256sums = SKIP
pkgname = gtk-sharp-2-git
diff --git a/PKGBUILD b/PKGBUILD
index a5ba93cd94b9..db78efbccacd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,24 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: mrAppleXZ <mr.applexz@gmail.com>
+
pkgname=gtk-sharp-2-git
-pkgver=2.12
+pkgver=2.12.45.r48.ga915b2c67
pkgrel=1
-pkgdesc="C# bindings for GTK+ 2, built from sources."
-arch=('any')
+pkgdesc="C# bindings for GTK+ 2"
+arch=(any)
url="https://mono-project.com/GtkSharp"
-license=('GPL')
-depends=('mono' 'gtk2' 'libglade')
-provides=('gtk-sharp-2')
-conflicts=('gtk-sharp-2')
-source=("git://github.com/mono/gtk-sharp.git#branch=gtk-sharp-2-12-branch")
-md5sums=('SKIP')
+license=(GPL)
+depends=(mono gtk2 libglade)
+makedepends=(git)
+provides=(gtk-sharp-2)
+conflicts=(gtk-sharp-2)
+source=("git+https://github.com/mono/gtk-sharp.git#branch=gtk-sharp-2-12-branch")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/gtk-sharp"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
cd "$srcdir/gtk-sharp"