summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-01-06 19:31:42 +0100
committerFabioLolix2023-01-06 19:31:42 +0100
commita98aabcdd36f47db94bbcc7f81276cd70a395d6b (patch)
tree52336ecfce667fd8261aba72e151740ab3364ed1
parent39c286e269baaed979addbdeb6e973068b7bba22 (diff)
downloadaur-gtk-sharp-3-git.tar.gz
revision
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 33 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6d8be1ad4f1..bb59a9920a2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = gtk-sharp-3-git
pkgdesc = C# bindings for GTK+ 3, built from sources.
- pkgver = 3.22.1
+ pkgver = 2.99.3.r76.gdadc19cf1
pkgrel = 1
- url = https://github.com/openmedicus/gtk-sharp
- arch = any
- license = GPL
+ url = https://www.mono-project.com/docs/gui/gtksharp/
+ arch = x86_64
+ license = GPL2
+ makedepends = git
depends = mono
depends = gtk3
- provides = gtk-sharp-3=3.22.1
+ provides = gtk-sharp-3
conflicts = gtk-sharp-3
- source = git://github.com/openmedicus/gtk-sharp.git
- md5sums = SKIP
+ source = git+https://github.com/mono/gtk-sharp.git
+ sha256sums = SKIP
pkgname = gtk-sharp-3-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ae95598f2bde..9b3988d8f561 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,36 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: mrAppleXZ
+
pkgname=gtk-sharp-3-git
-pkgver=3.22.1
+pkgver=2.99.3.r76.gdadc19cf1
pkgrel=1
pkgdesc="C# bindings for GTK+ 3, built from sources."
-arch=('any')
-url="https://github.com/openmedicus/gtk-sharp"
-license=('GPL')
-depends=('mono' 'gtk3')
-provides=('gtk-sharp-3=3.22.1')
-conflicts=('gtk-sharp-3')
-source=("git://github.com/openmedicus/gtk-sharp.git")
-md5sums=('SKIP')
+arch=(x86_64)
+url="https://www.mono-project.com/docs/gui/gtksharp/"
+license=(GPL2)
+depends=(mono gtk3)
+makedepends=(git)
+provides=(gtk-sharp-3)
+conflicts=(gtk-sharp-3)
+source=("git+https://github.com/mono/gtk-sharp.git")
+sha256sums=('SKIP')
-build() {
- cd "$srcdir/gtk-sharp"
+pkgver() {
+ cd gtk-sharp
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd gtk-sharp
./autogen.sh --prefix=/usr
+}
+
+build() {
+ cd gtk-sharp
make
}
package() {
- cd "$srcdir/gtk-sharp"
+ cd gtk-sharp
make DESTDIR="$pkgdir" install
}