summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzach-adams2015-09-23 08:33:14 -0600
committerzach-adams2015-09-23 08:33:14 -0600
commit759ec512cfefdbca5c93f9bb0a064638c82e3f49 (patch)
treef9ffa28bd679233860f8852fafb656782c562aff
downloadaur-759ec512cfefdbca5c93f9bb0a064638c82e3f49.tar.gz
Initial commit, release 20150922
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea28007dfa46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gtk-theme-arc
+ pkgdesc = A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell. Official releases only.
+ pkgver = 20150922
+ pkgrel = 1
+ url = https://github.com/horst3180/Arc-theme
+ arch = any
+ license = GPL3
+ depends = gtk3
+ depends = gtk-engine-murrine
+ conflicts = gtk-theme-arc-git
+ source = https://github.com/horst3180/Arc-theme/archive/20150922.tar.gz
+ sha256sums = 4cd69ce3fd611034c4d6be88840a23e8b9d3b6c95511459e764ff24e9e512e07
+
+pkgname = gtk-theme-arc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15e15f93d78d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: zach <zach {at} zach-adams {dot} com>
+# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
+
+pkgname=gtk-theme-arc
+_pkgname=Arc-theme
+pkgver=20150922
+pkgrel=1
+pkgdesc="A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell. Official releases only."
+arch=('any')
+url="https://github.com/horst3180/${_pkgname}"
+license=('GPL3')
+depends=('gtk3' 'gtk-engine-murrine')
+source=("https://github.com/horst3180/${_pkgname}/archive/$pkgver.tar.gz")
+sha256sums=('4cd69ce3fd611034c4d6be88840a23e8b9d3b6c95511459e764ff24e9e512e07')
+conflicts=('gtk-theme-arc-git')
+
+build() {
+ cd "${_pkgname}-$pkgver"
+ ./autogen.sh --prefix=/usr
+}
+
+package() {
+ make -C "${_pkgname}-$pkgver" DESTDIR="${pkgdir}" install
+} \ No newline at end of file