summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Crompton2016-07-02 04:14:16 -0500
committerTyler Crompton2016-07-02 04:14:16 -0500
commit15649544a4b265907e4f0a4bbe0b8aac0ffcd83b (patch)
treedfbfaf95e471f1f405b7efb108c30eb61f55d04f
downloadaur-15649544a4b265907e4f0a4bbe0b8aac0ffcd83b.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de189b92c3cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gtk-theme-arc-grey-git
+ pkgdesc = A flat, grey theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell. Latest commit from the master branch on Github.
+ pkgver = 605.4cb45e6
+ pkgrel = 1
+ url = https://github.com/eti1337/arc-grey-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ depends = gtk-engine-murrine
+ provides = gtk-theme-arc-grey
+ conflicts = gtk-theme-arc-grey
+ source = arc-grey-theme::git+https://github.com/eti1337/arc-grey-theme.git
+ sha256sums = SKIP
+
+pkgname = gtk-theme-arc-grey-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3f1f0da6b8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Étienne Baritaud Figueroa
+# Contributor: zach <zach {at} zach-adams {dot} com>
+# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
+
+pkgname=gtk-theme-arc-grey-git
+_pkgname=arc-grey-theme
+_pkgauthor=eti1337
+pkgver=605.4cb45e6
+pkgrel=1
+pkgdesc="A flat, grey theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell. Latest commit from the master branch on Github."
+arch=('any')
+url="https://github.com/${_pkgauthor}/${_pkgname}"
+license=('GPL3')
+depends=('gtk3' 'gtk-engine-murrine')
+makedepends=('git')
+source=(${_pkgname}::"git+https://github.com/${_pkgauthor}/${_pkgname}.git")
+sha256sums=('SKIP')
+conflicts=('gtk-theme-arc-grey')
+provides=('gtk-theme-arc-grey')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh --prefix=/usr
+}
+
+package() {
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
+}